You must be logged in to post messages.
Please login or register

Caesar IV: Game Help
Moderated by Gweilo

Hop to:    
Topic Subject: Caesar IV & Windows 8
posted 12-08-12 13:04 ET (US)   
Well. Guess I am done playing Caesar IV.

I installed Windows 8 three nights ago and this morning I reinstalled Caesar IV. During the install process it had me download the Microsoft .NetFramework.

Anyhow I tried playing to see how well it would work in Windows 8, I was previously playing it on Windows 7 without any problems but it won't work for me on Windows 8.

I started off trying to test it with my last saved game and it kept telling me the saved game was invalid then it would close the game client completely. Then I remembered I forgot to apply the 1.2 game patch thinking that was probably the reason why so I installed that but no dice.

I re-tried and re-tried to no avail. I then tried just running the default Kingdom & Republic games but they won't work either. The default scenarios would begin, I see the pre-game map of the city, listen to the narrator and then click the "Begin" button but in the process of loading the game map it gives me that error message again about the saved game file not being valid.

I tried running the game using the Windows Compatibility Mode set to Windows 7 (since it worked in Windows 7 for me before) but that didn't help either. I was really expecting that to fix it but it didn't.

I don't know what else to try.

I'll come back if I ever find a solution for this.

EDIT: (9+ hours later)

Okay I solved the problem and can play Caesar IV again. I am not sure exactly what fixed it or what caused the problem to begin with but here's the story in case it can help someone else in the near future.

Earlier this morning when I re-installed Caesar IV onto my fresh Windows 8 operating system I found out I was not able to play Caesar IV anymore. It worked for me in Windows 7 but not Windows 8. I tried the Compatibility Mode selecting Windows 7 and that didn't work. I even tried Compatibility Mode for Vista and again for Windows XP Service Pack 3 and those didn't work either. I grudingly accepted my fate of not being able to play Caesar IV anymore.

I went looking through old game discs for something else to play. I had Pharoah, Cleopatra, Zeus, Caesar III, and World of Tanks and several types of the Age of Empires games. I tried Cleopatra and Caesar III and also World of Tanks. Each of those didn't work either, it gave me an error message about missing the D3DX9_43.DLL file. After a lengthy search online for a reliable solution I came across this webpage on Microsoft's site -

It then led me to this page -

Even though Windows 8 includes DirectX 11.0 already I went ahead and downloaded and ran the file from that second link. That download does not overwrite existing files but it will add/replace anything that you may not have. After that install I was able to run World of Tanks so I knew it worked.

Meanwhile, back at the batcave (Caesar IV) I wanted to try and fix this issue about invalid saved game files that prevent me from playing and cause the game to exit. I did some more searching and I stumbled upon this post at the Tilted Mill forums -

I was like YAY! this will work. So I found the RegisterDLL.bat file the post spoke of, right-clicked it and chose Run As Administrator, it ran but unfortuntely it still didn't help me. So I said "P... on it!" and decided to uninstall Caesar IV and every folder it creates in your

"C:\Users\YOURNAME\AppData\Local\VirtualStore\Program Files (x86)\!MY INSTALLS\Caesar IV\" folder. I wanted to make sure I removed every trace of the game to get a clean re-install. I did not uninstall the MySQL that the game needs since that is a separate entity.

Anyhow, I reinstalled the game, didn't make any changes to the game settings, choose the first scenario in the Kingdom campaign and luckily I got in. Woot!

I paused the game and created a save of it to see if I could reload a saved game file. It worked.

I opened the Saved Game folder and put all my former saved games back into it and tried to run a couple. Boo! Hiss! They didn't work, but I didn't expect them too since I hadn't yet re-applied the game's 1.2 patch. I patched the game, changed the game settings to my liking and loaded up my Kingdom 1 saved game and it worked. I then gave the final test and tried to load one of my former saved games - the ones that were causing the game to crash 9 hours earlier and they worked.

Again, I don't know what broke to begin with or what ended up fixing it but here's my best guess looking back --

Windows 8 already comes with the latest update of DirectX 11.0 as I mentioned above so it shouldn't be causing me any problems. What I think happened though was when I first tried installing Caesar IV onto my fresh install of Windows 8, during the installation process Caesar IV wants to install DirectX 9. I allowed it thinking it would notice the updated DirectX 11.0 and the skip that part of the install but I think it may have overwriten some of the files.

So if you install Caesar IV and you are already running a newer version of DirectX just skip that part of the installation, you can always go back to the Caesar IV disc and install that part it if need be.

If you are unsure how to check what version of DirectX you have you can do this:

In Windows 7 and earlier (Vista, XP etc) click on the Start Menu button and find the Run link. Click that and in the Run box type "dxdiag" (no quotes) and hit enter. It will run a diagnostics on your system that you can save for future reference if you want. It will show you what version of DirectX you have among other things.

In Windows 8 press the Windows key + X and choose Run then do the same thing I mentioned above, type in "dxdiag" (no quotes) then hit enter to get your report.

I hope this helps.

[This message has been edited by Poorman (edited 12-08-2012 @ 10:42 PM).]

posted 12-09-12 02:10 ET (US)     1 / 18  
I'm glad you've got it working. I'm not surprised there was a problem with DirectX. Many people have had these sort of problems with Win 7.

Thanks for all the helpful info.
posted 06-07-13 20:16 ET (US)     2 / 18  
Windows 7 and 8 both come with a Windows Program Compatibility Troubleshooter.

I had problems getting my install of Caesar IV running on my new Windows 8 computer, but after running it through the PCT I got things going.

I have the boxed original version of the game, with the 1.2 patch file. I ran the normal install all except for MySQL which isn't needed now since the online part of the game is dead. I installed my 1.2 patch and tried to run the game but didn't have any luck.

I then found out about the PCT. If the program you are attempting to run is not on PCT list, then use the "not listed" option at the top of the list. Run the PCT application and let if finish.

If that pass didn't work, you may have to apply the "run as administrator" option on the PCT menu first before processing the game through the PCT.

I also had to use PCT to get another of my games (World in Conflict) running. The game also had to be set in the administrator mode.

Caesar IV will occasionally just stop running for some reason on Windows 8. So it is advisable that you have your automatic save turned on. Otherwise you'll lose all the progress you have made in your city when the game just stops running and you have to restart the game. I have my save mode set to make a save every 60 seconds, since I tend to make a lot of changes in a city in a short time.

I also recommend making manual saves after you have made more than one or two significant changes to your city just as a backup, because every once in a while the last save file will be corrupted when the game stops running.

You'll know when it happens because there will be a small warning box popup telling that Caesar IV has stopped running and you need to close the application.

Community Moderator for the former Sierra for Caesar III, Pharaoh/Cleopatra, Zeus/Poseidon, Emperor, Lords of the Realm II/III, World in Conflict.
Core beta tester for Pharaoh, Cleopatra, Zeus, Poseidon, Emperor, Lords of the Realm III, and all their patches.
Core beta tester for Tilted Mill's Children of the Nile. Selected as a Tilted Mill "Luminary".
Beta tester for Civilization III: Conquerors by Sid Meiers, A Force More Powerful by BreakAway Games, and Arabian Lords for Breakaway Games.

[This message has been edited by Keith Heitmann (edited 06-07-2013 @ 08:26 PM).]

posted 06-08-13 03:59 ET (US)     3 / 18  
Hi! I also have a problem running C4 on my 64 bit Windows 8 computer: The game works otherwise fine but while I play campaign scenarios the game freezes whenever I get a notice of a demand or request. The weird thing is that if I play a custom scenario, or a campaign scenario as a single scenario (I used a cheat to unlock them all just to test this), the requests work just fine.

Has anyone had similar problems?
posted 06-09-13 01:50 ET (US)     4 / 18  
I have not seen that problem before.

Normally, if you have the Settings > Interface > Message Pausing Options check marked the messages will pause until you clear them. If you uncheck all the boxes in the Message Pausing Options they will clear themselves.

I'm not sure what is causing your problem if you have those options turned off.

Have you tried different compatibility modes? Maybe one will work better than the others.

Community Moderator for the former Sierra for Caesar III, Pharaoh/Cleopatra, Zeus/Poseidon, Emperor, Lords of the Realm II/III, World in Conflict.
Core beta tester for Pharaoh, Cleopatra, Zeus, Poseidon, Emperor, Lords of the Realm III, and all their patches.
Core beta tester for Tilted Mill's Children of the Nile. Selected as a Tilted Mill "Luminary".
Beta tester for Civilization III: Conquerors by Sid Meiers, A Force More Powerful by BreakAway Games, and Arabian Lords for Breakaway Games.
posted 06-14-13 01:16 ET (US)     5 / 18  
I thought I had tried out all the compatibility options, but one finally worked out:

I set the compatibility mode for Windows XP (service pack 2) and set on the 'run as admin' option. This alone didn't work, but I then checked the box to apply these settings for all the users and now the crashing problem is finally gone. The weird thing is that I only have one user account.

But well, with pc things seem to follow some mystical semi-randomly interpreted dogma rather than simple logics.

Thanks for the advice, nonetheless.
posted 01-08-14 22:29 ET (US)     6 / 18  
hiya guys and girls. I need serious help..
I have been trying to run Caesar iv for the best part of a week with still no joy.
I loaded the game no problem, oh I'm on a windows 8.1 laptop system, when I click play it tells me to insert the correct disc not a copy (I seen someone had the same message) I contacted securom and they have been emailing and returning analysis sheets for the best part off 3 days! they even at one point had the cheek to tell me nothing was wrong.
anyway I read through many comments about this problem, a lot of people seem to find. and I tried everything I can read. securom sent me a new caesariv.exe file which is bigger then the original which they told me to put into the program file of caesariv. I have downloaded patch1.2 and added that to the file, that's great.. I have run the program in several compatible modes including the ones recommended, I have ran it as admin and without. I have uninstalled the game 4 times already and even reset my computer to windows 8 and still haven't installed the update to 8.1 in case it was that causing the problem again I tried all different ways I reloaded everything again (patch, exe, etc) and nothing I've seen this thing about directx being wrong so I clicked on the link in the first post and downloaded the fixes for 9.0c although I have directx11 and still nothing.

please someone give me a small clue to how I can get this working so I can tell my dad it was worth me losing all the pictures on the laptop when I reset it (ooops)
posted 01-09-14 03:38 ET (US)     7 / 18  
Hi Deej81.

Are you saying that you still get the error "please insert disk" with the new EXE file supplied by the securom people?

Or do you have a different error when running the securom EXE?
posted 01-10-14 02:41 ET (US)     8 / 18  
yes I still get exactly the same error message no matter what I do! I'm startng to actually think we were sold the back up (copy) disc lol

update: the Laptop crashed early this morning doing something else so I had to master reboot it. I have updated everything possible including 8.1 (I know sorry)
again I have loaded the disc done directx end-run, patch 1.2 (i have a feeling this doesn't work properly as it says it takes min 6 min but it takes seconds on my laptop - also I can't update 1.0 to 1.2. it thinks I already have 1.1 and therefor I have to choose the other download.
re-installed the new caesariv.exe after renaming the orig to ceasariv.exe.OLD as asked.

oh yeah and I still get the same message after all that!
posted 01-11-14 02:20 ET (US)     9 / 18  
Well, I'd expect the new EXE from SecuROM to work. You're not running any virtual drives are you? Programs like Daemon Tools can cause this sort of problem.

Did you try Keith's suggestion of deleting the previous SecuRom data? (TM forum, not this thread)

If none of this works, you could post in the technical forum, linking to this post, and PCDania may be able to help. He is really good with the technical stuff.

I'm sorry I don't know enough to offer further help.

[This message has been edited by kach (edited 01-11-2014 @ 02:21 AM).]

posted 01-11-14 03:57 ET (US)     10 / 18  
I've kept an eye on this thread and the only suggestion I can add is trying to disable UAC (User Account Control) in Windows 8.1 and see if that solves the problem.

Please note: UAC is part of the system protecting the computer against malware so it is important to enable it again after each gaming session.

To disable most functionality of UAC, go to Control Panel and select "User Accounts and Family Safety" --> "User Accounts".

Choose "Change User Account Control Settings" and move the slider to the left all the way down. Note: you might have to restart the computer for the change to take effect. For activating UAC again simply move the slider back to the setting it had before.

There is a more thorough way for disabling UAC but it requires more work and disables all programs that require the Metro user interface for running. As it is best to only disable UAC during the gaming sessions I can not recommend trying this method.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.
posted 01-12-14 16:30 ET (US)     11 / 18  
Thanks for your suggestion PCD. I hope Deej81 comes back. I'd like to know if he/she gets this problem resolved.
posted 01-15-14 00:56 ET (US)     12 / 18  
I ran the securom and it said there was no other version,

how do I know (and stop) any daemon tools? this maybe the answer to this problem!
posted 01-15-14 15:50 ET (US)     13 / 18  
If you haven't installed Daemon tools, then you don't have them.

Did you try PCDania's suggestion about User Account Control?

I'm sorry Deej81, I haven't used Windows 8 and I don't know what's causing the problem.
posted 01-19-14 15:51 ET (US)     14 / 18  
hey everyone thanks for all your ideas n solutions i'm affraid to report after trying them all I still have no joy getting the game to run. as a result i am going to purchase another disc (this time new not 2nd hand) from amazon and see if that will work for me.
posted 01-20-14 03:52 ET (US)     15 / 18  
What about a digital version? I see that Caesar IV is available from the Activision store for $14.99.
posted 06-12-15 23:11 ET (US)     16 / 18  

[This message has been edited by Pecunia (edited 06-15-2015 @ 11:42 AM).]

posted 06-12-15 23:15 ET (US)     17 / 18  
The last post is spam.
posted 04-11-23 21:56 ET (US)     18 / 18  
@Keith Heitmann - THUMBS UP - for this notice in your post ---I also recommend making manual saves after you have made more than one or two significant changes to your city just as a backup, because every once in a while the last save file will be corrupted when the game stops running.---
it saved me hours of time waste as I already had reinstalled latest DirectX version and after running compatibility program with my Win8.1 OS still got the game crash with last save file!
At your advice I simply loaded a previous save file (just the last before last..) and the game run as always.
Thank you! Well Spotted detail!
On the other hand @Poorman Thank you too for your post. Your work exposed even maybe not professional but can help many people.
I didn't went though for your fix as from my experience now I always try the easiest things before to go deeper...'check the power cable's fuse first if your device is not starting'. This help surely to not waste time as for me this case.
However your fix can work in other cases.
Cheers and good gaming!

[This message has been edited by Jades8 (edited 04-11-2023 @ 09:59 PM).]

Caesar IV Heaven » Forums » Caesar IV: Game Help » Caesar IV & Windows 8
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames