You must be logged in to post messages.
Please login or register

Emperor: Game Help
Moderated by Gweilo

Hop to:    
Topic Subject: Bug List
« Previous Page  1 ··· 3 4 5  Next Page »
posted 10-07-02 23:06 ET (US)   
Thought it might be useful to keep track of the bugs. Here is what I have compiled so far.

1. The Zodiac Bug - where creating a 2nd family resets all your zodiac animals to Rat

2. Animal Request Bug - where you can't dispatch an animal to comply with a menagerie request.

3. Editor City Map Selection bug - in the editor, where you select the city maps for your player cities, if you have more than 100 or so maps in your cities folder, the list cuts off after the first 100.

4. The Two Heroes/No Hero but there He is/Frozen hero bug - two exalted heroes in your city can really mess up your heroes. workaround, dismiss the frozen hero.

5. The Replay Scenario bug - using Replay Scenario option doesn't reset all the game data.

6. The Multiplayer Difficulty Bug - In multiplayer, the host's difficulty setting does not over ride your previous setting, so while everyone else is on Normal or Easy, I'm on Very Hard. Everyone should be on the same difficulty. Workaround - set your difficulty to Normal or Easy before joining multiplayer games.

7. Troops don't return bug - I haven't seen this one myself yet, but it's been reported more than once.

8. The Tax Bug - awesome work by Nero Would determining that the taxes reported by the overseer do not equal the taxes reported by the individual houses.

9. The Positive Appeal Bug - residential walls are supposed to block both good and bad desirability. They only block the bad, the good still passes through. I like to think of this one as more of a feature, but it's not working as advertised so by definition is a bug.

10. Save Game bug - saving and reloading from that save causes your for sale signs to turn to huts and adversely affects immigration rates. Workaround: Exit Emperor completely and restart it. You can then load the saved game.
Edited, thanks Jim and Grumpus

11. Religion Coverage Bug - sometimes when you add religious buildings and have religious coverage, it's still not registering on the Religion Tab summary. Workaround: save and reload to update the religious coverage meters.

12. Cliffs at the Edge of the Map Bug-- This one is more of an eyesore that really doesnt affect gameplay from what ive seen. Ive created a few maps where there are elevations leading off the maps. If you have more than a 1 level elevation riding the edge it creates black holes, and those wierd blue tracking dots. The only way Ive found to work around it is to keep the elevations one tile away from the edge. This only seems to effect the bottom edge when the map is oriented north, and the eastern (right) edge.

13. Deleting Workcamp/Guild during Monument Construction can freeze the monument while it waits on a worker that's not coming back. Workaround: don't delete any monument building if there is a chance that building has a worker at the monument.

14. Military Morale Bug: When you place a fort (or several of them) and then turn the fort “off” (set it to “not working”), the soldiers will lose all their morale, even though the fort is empty (no soldiers in the fort)! I was mystified when this kept happening. I liked to place my forts while laying out the city – lay out and set up my military section of the map -- because forts don’t need inspector access, they could remain in place as “not working” without taking any harm. When I got suspicious I tested the not-working forts every couple of months and sure enough, they steadily began to lose morale as time passed and they remained not-working.

A related bug: When your troops return home from a distant battle, they will physically return to their forts but their status will be “Still” instead of “At fort.” They will lose morale until you actually give the command to each troop to return to their fort. They won’t go anywhere, but their status will change from “Still” to “At fort” and their morale will remain steady (or improve at normal at-fort levels if they were feeling blue after losing a battle).

15. The Menagerie Score Bug - the manual states (page 122) you get points for a menagerie, even when it's not a goal. Those points are not being reflected in the Player's Score. The line for the Menagerie points is there, but you get Zero for it.

16. Gifting an animal does not improve favor or show up in the history.

17. Farm Production/Irrigation - Still researching, but it seems apparent that something isn't right. See this thread for details.

A Tale in the Desert
Flogging will continue until morale improves.

[This message has been edited by Merepatra (edited 11-12-2002 @ 08:45 AM).]

posted 11-14-02 13:24 ET (US)     101 / 126  
Fishing quays can become corrupted during combat. This is a bug I just found out recently. It was verified by a playtester who had reported it a long time ago (it was never fixed); see the Emperor forum at Sierra for additional info.

What I've found is that if a fishing quay gets set on fire during an attack, it will never recover. It never repairs even when water is thrown on it, and if you try to delete it, it just remains. Long after the battle ends it will just be sitting there, dormant. The other problem is that sometimes during nearby combat a fishing quay gets its graphic corrupted. It changes into a different graphic and when you right click on it you get information from a nearby structure. Don't dare delete it or you will also delete the nearby structure. What this bug currently means is that fishing is extremely vulnerable to military attacks, and even the shore space the fishing quay occupies can become permanently unusable. Hopefully this can be fixed in a patch.

My apologies if this has already been reported here, I didn't take time to check before posting.

posted 11-14-02 13:47 ET (US)     102 / 126  
I have problem with feng shui in Sui - the enlightened one. I was trying to place a trading station, but could not get a green footprint until I deleted one or two sections of city wall. I didn't think the city walls affected feng shui?

Also, in Sui - an agricultural community, on of my allies asked for millet. I am almost 100% sure that when I dispatched the millet it was not deducted from my storage yards. I noticed this problem in another episode involving fish.

posted 11-14-02 14:12 ET (US)     103 / 126  
Kach, did you have Shen Nong in the city at that time? If so, he will fulfill all food requests without touching your storages

Angel Pecunia | HG Downloads programmer and techie
Caesar IV Heaven | Children of the Nile Heaven | Citadel of Poseidon (Zeus/Poseidon) | The Great Wall (Emperor)
posted 11-14-02 19:50 ET (US)     104 / 126  
Thanks Pecunia. I hadn't realised he did that! Another one of my not very bright days.
posted 11-19-02 12:54 ET (US)     105 / 126  
I have a major problem with City Gates, and I don't know if it's a bug or not ...

The problem is simple : I can't place a city gate. My computer keeps telling me that I have to build on cleared land (which ofcourse, I'm doing at that moment). I first had the problem during the Walls of Zhengzhou, but didn't mind it all that much, since there where allready gates placed. But now I'm playing Edge of the Ordos, and I can't place a gate to secure my city . Has anybody had this problem and what should I do about it ???

Thansk in advance !

posted 11-19-02 13:04 ET (US)     106 / 126  
It's not a bug, you just have to do it correctly. See the thread City Gate for more information.

1) Road must be in place.
2) Must have a minimum of two wall tiles placed on both sides of the road.
3) The foot print of the gate is 5x3, so there cannot be anything adjacent to either side of the wall tiles.


[This message has been edited by VitruviusAIA (edited 11-19-2002 @ 01:05 PM).]

posted 11-19-02 14:42 ET (US)     107 / 126  
It's also possible you may have encountered something else I noticed. On a couple of maps, I've run across tiles that can't be built on. I right click on them and they say grass, excellent for building. Then when I try to place something they tell me you need to build on clear land. I try clearing the tile, nothing, and I still get the same can't build message. So its possible even if you're doing everything right on the gatehouse, that it still may not be able to be built because one of the tiles is a "rogue" one.
posted 11-19-02 15:07 ET (US)     108 / 126  
Jim could it be that its´s a spawn point for animals.

|-->--->Kamikaze San<---<--|
posted 11-19-02 15:12 ET (US)     109 / 126  
It's possible. There were three of them and alligators near by, but it was ten tiles in from the water; wouldn't they spawn closer to water? And if it was, shouldn't the warning be you can't build on a spawning spot, rather than a warning to build on cleared land?
posted 11-19-02 16:27 ET (US)     110 / 126  
I took a look at the thread posted on City Gates and it seems like it will solve my problem .. I'll try it out tomorrow afternoon (a bit too lazy to start up my other PC at the moment). Thanks alot !
posted 11-19-02 20:48 ET (US)     111 / 126  
Judging from the cycle on previous games, if something won't work, like it's impossible to finish an episode, that can happen in a couple of weeks.

If it's mostly stuff that's inconvenient, unattractive, or illogical, or related to extended playing patterns such as replaying a saved game, 3-6 months after release is pretty typical, with a second patch with an upgrade several months after that.

posted 11-20-02 06:28 ET (US)     112 / 126  


shouldn't the warning be you can't build on a spawning spot

Yes it should but I had that once to I did´nt read the hole message

Just a ges,was there a salt march in the area.

|-->--->Kamikaze San<---<--|
posted 11-20-02 12:33 ET (US)     113 / 126  
In my case, it never said it. I've seen the warning before, but I can't remember if it was in Emperor or one of the other games.

Quoted from Kamikaze San:

Just a ges,was there a salt march in the area.

No, there was no salt marsh anywhere on the map. It was close to some bamboo if that means anything.

posted 11-25-02 09:25 ET (US)     114 / 126  
Not sure if this has been posted (don't have time to look around and I can't find any search function :S)

But I shut down a farm whilst it had allready 'emitted' farmers... the farmers happily continued farming... (the 22 workers were gone)

"Insanity: Doing the same thing over and over again and expecting different results" - Albert Einstein
posted 11-25-02 10:03 ET (US)     115 / 126  
GoneWacko I tried what you described.
I have shut down my farm when it had emited 2 farmers eventualy the farmers wil return to the farm so I set the farm to "working" again the other farm had 6 farmers but the one I messed with,only had 2 farmers the whole season.
Strange huh!

|-->--->Kamikaze San<---<--|
posted 11-25-02 10:08 ET (US)     116 / 126  
Keep watching. The gift of Cash is deducted when the Emissary arrives in the foreign city. Likewise with other gifts.

Extend your grasp of the Empire at Serpentineum
posted 11-25-02 13:24 ET (US)     117 / 126  

Quoted from MarvL:

The gift of Cash is deducted when the Emissary arrives in the foreign city. Likewise with other gifts.

My observations have been that the cash is deducted when the emissary leaves your map (city) and gifts of goods are gone from your warehouses right when you make them, not when the other city receives them.

posted 11-25-02 14:20 ET (US)     118 / 126  
Found another WEIRD one...

I'm currently playing the SHANG dynasty (i'm not that good at emperor [i'm following the walkthrough hahaha]) and I had the mission were you have to build a Great Temple ( mission 3 I think)

I have this picture a tooltip that appeared when my mouse was over the question mark icon (help icon) on the screen you get when you right click the temple...

(you can request it by email @

Somewhere in my city was a desease, and I somehow got the tooltip 'go to site of desease'...

On the picture I can email, you won't see my mouse pointer... So you'll just have to trust it's not photo manipulation :P

"Insanity: Doing the same thing over and over again and expecting different results" - Albert Einstein
posted 11-26-02 01:44 ET (US)     119 / 126  
Greetings GoneWacko,

It's not a bug, just a feature of the game.

When an bad event occurs somewhere in your city (disease, fire, collapse, etc.) a window will pop up and tell you so, also giving you a button to jump right to the hotspot. They'll pop up whenever a problem occurs, even if another window is open.

Now off to bed, methinks.

posted 11-26-02 08:31 ET (US)     120 / 126  
but the tool tip should not appear over the 'help icon'!!!

"Insanity: Doing the same thing over and over again and expecting different results" - Albert Einstein
posted 11-29-02 22:20 ET (US)     121 / 126  
Hmmm, you're right. Erm...*scratches chin*


I know wierd things can start to happen when you've been running Emperor for extended amounts of time. So moral of the story: take a break every so often!

As to what it could really be, I haven't a clue. Maybe just a random glitch.

Hunter of Gremals, Krugs, Wabbits, Wolves, and that sniveling little DePuce who made a mockery out of my name!
posted 12-04-02 03:46 ET (US)     122 / 126  
*scratches chin in puzzlement*

Has anything ever been said on recaptured animals being added back to the menagerie?

For example: Just finished the last mission in the Song-Jin campaign. Mid-way through, Mongols invaded, caused general mayhem, and destroyed the palace in the process - releasing the lone vulture.

Skip ahead: the mongols are defeated and cleanup is underway. Now, the vulture is stuck behind a house, so I summon hero to capture the pesky critter. Hero arrives, Hero captures vulture, leads it back to the palace and deposits it back into menagerie - or so I thought. The bird just disappears. Poof!

Now I know that when a previously captured animal escapes, it'll try to escape out the closest exit (if it isn't in it's proper climate). Is this just a variation on the theme, or something that isn't quite supposed to be happening?

Any input would be welcome.

Hunter of Gremals, Krugs, Wabbits, Wolves, and that sniveling little DePuce who made a mockery out of my name!
posted 12-05-02 08:35 ET (US)     123 / 126  
Rat, was your palace at full-employment when the recaptured animal was brought back there ? If it wasn't fully staffed, maybe that was why it went poof ?
posted 12-05-02 18:03 ET (US)     124 / 126  
Yep, Palace has full employment. Just tried this again with a different mission (Han Campaign), got the same result.

1.) Built Palace
2.) Requested an Animal - recieved Saiga Antelope
3.) Destroyed Palace - Antelope escapes
4.) Antelope gets stuck in Housing Block
5.) Summon Hero - captures antelope - leads it back to Palace
6.) Antelope disappears again - Palace has full employment

Odd, is it not? Eh, not really a problem though. Just found it a bit strange.

Although the hero could be getting the munchies

Hunter of Gremals, Krugs, Wabbits, Wolves, and that sniveling little DePuce who made a mockery out of my name!
posted 12-18-02 04:05 ET (US)     125 / 126  
is the 1st post @ the top updated regularly or the bugs r posted as & when found?
Thanx in advance.
posted 12-18-02 04:40 ET (US)     126 / 126  
The top post has been updated when definite new bugs are found though homegrown who was doing it is away at the moment so I'm not sure if its completely up to date.

Breakaway has looked at all the reported bugs and the patch will be addressing these issues.

« Previous Page  1 ··· 3 4 5  Next Page »
Caesar IV Heaven » Forums » Emperor: Game Help » Bug List
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames