You must be logged in to post messages.
Please login or register

Zeus: Adventure Design
Moderated by Gweilo

Hop to:    
Topic Subject: Zeus / Poseidon - Bug List
« Previous Page  1 2  Next Page »
posted 09-24-06 16:34 ET (US)   
There are only two real bugs in Zeus / Poseidon that weren't addressed by the 2.1 patch (did anyone else spin Horse Ranches around like a propellor when that patch came out?), and both are fairly easy to work around:

1 - problem sometimes when you place a Cattle Ranch in a game, it won't let you place any Cattle (it will tell you to build another Ranch). This is due, probably, to the regenerative capabilities of the Cattle Ranch; every once in a while, a rancher will bring a calf out to the meadow to replace Cattle taken.
1 - solution as soon as you place a Cattle Ranch - before it becomes fully employed - place your Cattle on the meadow. As long as you can get 1 Cattle in place, you should be fine. If all else fails, save your game, exit Poseidon, and reboot your computer. When you restart Poseidon, immediately place Cattle and you should be fine.

2 - problem in the "Buildings Allowed" section of your settings, you normally click on an item (and turn it yellow) to prevent that item from showing up in that map. However, the Gazebo and Flower Garden are reversed... click on a Gazebo to keep it from showing up, and it still does - but the Flower Garden won't appear, and vice-versa.
2 - solution just remember that they're reversed... if you don't want people to be able to place a Flower Garden, click on the Gazebo in your settings to disallow it, and vice-versa.

Both of these are fairly easy to work around, and only one - the Cattle - can be a problem for the player. Both solutions work, making these minor bugs very survivable.

David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis
posted 09-27-06 06:17 ET (US)     1 / 31  
And here I thought I was the only one propelling my Horse Ranch. I think I even went "Wheeee"

I haven't encountered the Cattle Ranch problem yet, but it's a nice reminder.

Hehe, and that is a peculiar little bug, the Gazebo and Flower Garden reverse... Haven't noticed it before, but that's probably because I usually allow or disallow them both.

Susie, if you want to see your doll again, leave $100 in this envelope by the tree out front. Do not call the police. You cannot trace us. You cannot find us.

Sincerely, Calvin.

[This message has been edited by Woutichon (edited 09-28-2006 @ 04:37 AM).]

posted 09-29-06 00:42 ET (US)     2 / 31  
I usually disallow either one or the other in the initial eps of an adventure; the Gazebo has a higher Aesthetics rating than does the Flower Garden.

(Yeah, I sat there for a while spinning the Horse Ranch around... after all the bitching we did about that particular problem, it was nice to see that they addressed it).

David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis
posted 10-25-06 00:08 ET (US)     3 / 31  
One final 'bug' for Poseidon... though it doesn't really affect you in any way.

The longer you've been building your city, and the larger it is, the more likely you are to run into this one.

If you've got several pyramids of the same type built in your city (such as three Major Shrines), click to the Aeshtetics tab, and click on the magnifying glass... it will list each pyramid as the same one, with the same completion date.

The only thing this affects in the game is this details screen... it doesn't affect your goals any.

Also note that if you have a large city (5,000 inhabitants or more), then things are likely to be a bit slow in the realm of Distribution. No matter how close your food sources (Farms or Piers, etc) are to your Granaries or your housing, your Granaries will be empty or near empty a lot of the time - cart pushers will slow down quite a bit in a large city. The only real way to compensate for this is to have quite a bit more food than you actually need; if you only need enough food for 5,000 people per year, then make sure you actually have enough for 8 or 9,000.

Other distribution - such as Fleece, Olive Oil and Wine will also slow down, but nowhere near as much as your food.

David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis
posted 10-25-06 08:02 ET (US)     4 / 31  
Is there some kind of bug with getting trade to reopen after you conquer another city? I've seen players comment on this, most recently here.

Expand your fun by downloading free custom campaigns for Emperor: Rise of the Middle Kingdom.
Visit Zeus Heaven to expand your knowledge of Zeus and Poseidon.
posted 10-25-06 22:44 ET (US)     5 / 31  
No bug, just patience. It can sometimes take up to three years for a conquered city to start trading with you. One way to speed up this process a bit is by raising their feelings towards you with a large gift of something they need (or a huge chunk of money); the best time to do this is as soon as you've conquered them.
The thing to remember is that trade depends on goodwill as much as anything else - if they don't like you, they won't trade.

David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis
posted 03-11-07 19:20 ET (US)     6 / 31  
Zeus/Poseidon bugs:

In regards to the Cattle ranches: It is also possible to end up with a cattle industry that won't support as many cattle as it is supposed to. This seems to happen when sanctuaries are sacrificing cattle. The sanctuaries apparently don't pay attention to the ranchers' tally of allowed cattle, meaning that the herd size slowly decreases over time. Saving and restoring solves this problem, just like the above cattle problem. No restarting the game is necessary (in my experience). I would suggest keeping cattle ranches out of episodes with sanctuaries to avoid this.

In regards to the traders not arriving in a timely manner, I've noticed this myself and did some experimentation. Waiting for extended lengths of time produced no traders, however, as soon as I would save and reload the game, the missing caravan pops up within seconds. Trade ships take longer, but always show up within a month. So, either there is a bug with caravans not showing up on time, _or_ there is a bug with the game forgetting to save the fact that the caravans aren't arriving on time and it also isn't giving a 'associated city not trading' message when caravans aren't showing. Either way, there is some sort of bug here.

Some other bugs (And yes, as far as I know, I have the latest patch):

When Zeus is attacking the city, if the palace is destroyed and repeatedly rebuilt, there is a bug whereby some of the units become confused and think that their standard is a tower or something. You can still order the units around, but their standard won't be visible. This would be okay, but for the second part of this bug: maintanence offices (and possibly other buildings) stop producing walkers. I _think_ that if the palace is deleted, they will start working again, but only so long as the palace stays deleted. This would actually almost be a cool Zeus curse (he is supposed to be nasty after all), but I am pretty sure it is a bug.

Solution: You are completely and totally screwed. Restart the scenario. To avoid, don't rebuild palace until Zeus has his fun, or rebuild it way far away, so he has to walk a long way to walk.

Roads up cliffs: If you place a road right next to a cliff, then build a boulevard on it, it places a road where the edge of the boulevard overlaps the cliff. This produces some nasty visual glitches and a road up the cliff that cannot be deleted. It also seems to allow people to walk up and down the cliff, even if the spot would otherwise be inaccessible. Of course, I consider this cheating, so don't use it.

Partially destroyed buildings: Certain buildings, when destroyed in a transitional state, may leave pieces of themselves behind. These chunks often cannot be deleted and serve as a permanent impediment. I've seen this most often with trade buildings/warehouses, when someone deposits an item at the instant the building is destroyed. The dock part of a trade wharf can also get stuck if a ship starts trying to trade at just the right instant. I even saw this with my palace once. Was really annoying to have my nice fortified compound permanently jammed up. Curse you Zeus! The only solution that I know of, other than restarting the scenario or just building around the glitched spot is to get very lucky and have a tidal wave take out the building fragment in question. This actually happened once.

A related glitch can result when a landslide falls on an operational hippodrome. Apparently, the racing horses don't notice that the hippodrome is gone soon enough and you end up with some ugly (but not harmful) visual glitches.

Speaking of landslide problems, if a landslide falls "on" a sheep or goat, the sheep or goat survives, but can be permanently embedded in the cliff wall. The only way I know of to get rid of it, so as to be able to place one that your herders can get at is to delete all the sheep/goat buildings and wait for the animals to die off, then replace the buildings and animals. Exploiting the boulevard bug listed above might also work, but I've yet to try this.

Non-invasions: If you place an invasion point in a forest, invasions won't be able to arrive there and the player will get a 'bribe for 1 drachma' option. If they choose to fight, there of course won't be any troops.

Solution: Delete the forest under the invasion point and replace with a very thick scrub square. The dark green will look the same and the invasion will arrive properly.

Poorly synchronized invasions: While coming up with nasty things to do to the player, I hit upon the idea that an enemy might approach the city, then circle around it and attack from multiple directions. To make this look/work, I tried having one invasion set with 3 months warning and the other invasions set to occur 3 months later with 0 months warning. During testing, I discovered that the invasions were sometimes arriving together and sometimes not. I threw together an experimental scenario to try to figure out what was happening. This scenario involved both 3 month warning and 0 month warning invasions every month. I gave the invasions differing numbers of men each month, so I could tell by the bribe numbers when they were supposed to arrive. After a bit of trial, I discovered that the problem seemed to be related to the start of the year not matching with the start of the scenario. If I ran the scheduled invasions in the first episode, everything worked out fine. If I copied the invasions into the second episode, ran the first episode a few months, then went into the second episode, I discovered that the timing was fine until January, at which point things went haywire and invasions started arriving at the wrong time. It might be possible to solve this problem by using a yearly production goal to end the previous episode, forcing the year and episode starts to coincide.

The above situation also revealed another bug, whereby bribing a force from a city, no matter how small the force is, bribes all troops from the city, even though you only have to pay for the group that just arrived.

Fishing docks/water crossings on flooded coastlines: When a permanent flood alters the coastline, spots that contained forests cannot be used to place fishing docks, even if the flat section of coastline _looks_ like a fishing dock should be possible there. The forest can also placement of water crossings in the newly flooded zone. Apparently, the forests are still there, but can no longer be deleted or otherwise interacted with (if you could place a water crossing, It wouldn't surprise me if you could exploit the forest for lumber though. Would be pretty funny, chopping up the water crossing for lumber).

Solution: As a player, remove forests from where the flood will be, before the flood occurs. As a scenario designer, don't put forests on the very edge of the flood zone. (The non flooded squares next to the flood zone are okay.) While you could try to use this to keep players from building on a flat stretch of flooded coastline, you can't count on the player not clearing the forests. Just don't make flat coastlines if you don't want water crossings/fishing docks there.

Lava visual glitches: Although lava can go up or down rocks just fine, it usually produces nasty visual glitches, which is probably why you don't usually see scenarios with actual cone shaped volcanoes. There actually is a workaround to this however. By placing the 'half-slope' terrain feature either on a corner, or three in a row, you can create a larger 'half-slope' rock formation, which takes the place of individual half slopes. This formation is indestructible, just like any half-slope/cliff face. It also has visual priority over a lava square, meaning you can safely run lava flows under it, allowing the creation of really neat looking volcanoes.

posted 04-30-07 03:17 ET (US)     7 / 31  
I'm kinda new at this.

I finish a nice map, everything works, except I can't build horse ranches. I've try going into the "allowed building" menu and tried with both on and off. Neither works. I have Zeus, Zeus, Zeus Enhancement Pack, poseidon, poseidon patch 2.1 (installed in that order).

posted 04-30-07 07:43 ET (US)     8 / 31  
Hi Artius, welcome to the forum. What you mention doesn't sound like a bug, better open a new thread on that, and tell exactly what you are doing.

[This message has been edited by joshofet (edited 04-30-2007 @ 07:43 AM).]

posted 03-24-08 20:15 ET (US)     9 / 31  
lol i think i have found a bug...
when u create and adventure using posiedon adventure and u try to play it a popup comes up and says unable to load map, it's to old... But it continues on to the Parent map but only teh spwan points of the wolf and boar stayed.

I will explain it in detail here. (WHEN i did this i did teh Parent and World Map with about 10 events) I wanted to test out my adventure so i tryed to find my adventuer in custom games in Posiedon but it wasn't their. I looked on Zeus's custom adventure's at wasn't there either so i went to teh directory where teh .txt, .map and .pak files are. But i soon realised that the .pak file was a .set file so i changed the file extension to .pak and tryed to play it agian. I found my adventure in teh custom games on Posiedon and then what i said up top happened. I dont no if this is a one off but it is really pissing me off. (angry)

lol if any wants to reply to this do so....
posted 03-25-08 04:51 ET (US)     10 / 31  
As Pecunia explained in the thread below, this is not the way to create a .pak file, no bug seems to be involved.

[This message has been edited by joshofet (edited 03-25-2008 @ 04:53 AM).]

posted 03-25-08 05:28 ET (US)     11 / 31  
lol... i just realised how to create the adventure -> Menu -> Create Adventure... btu its fun to c wat things can happen... im so blind
posted 01-24-09 01:08 ET (US)     12 / 31  

[This message has been edited by Gweilo (edited 01-24-2009 @ 07:20 AM).]

posted 01-24-09 05:44 ET (US)     13 / 31  

[This message has been edited by Gweilo (edited 01-24-2009 @ 07:20 AM).]

posted 05-03-09 01:19 ET (US)     14 / 31  
After building a city with a population of 15k in beginner, for my last 3 out of 10 companies of houses, the peddler isn't coming out for a long time during which all my houses are dropping to huts. And to add, the agora's have all the supplies and surplus waiting in storages nearby, but the peddler isn't out delivering.
posted 05-03-09 05:33 ET (US)     15 / 31  
Hi pro, and welcome

Better post this as a separate thread in the game help forum, not sure this is a bug, and it certainly is not involved with scenario design (unless you think this may be caused by a flaw in the map you made yourself). You may have hit the walker sprite limit. Do you have many goats?

[This message has been edited by joshofet (edited 05-03-2009 @ 05:36 AM).]

posted 08-05-10 14:45 ET (US)     16 / 31  
I wondered what this bug is.

I have the Zeus and Poseidon Expansion and Patch 2.1, and have problems with oranges in granaries. After some hours of gameplay - ca. 25-29 years of ingame time, food vendors cannot use oranges stored in granaries anymore. On their way to the granary, they simply disappear when they reach the granary. It does occur only after some hours of gameplay, never at the beginning though.

This happened with every scenario I built in the Adventure Editor, either Greek or Atlantean.

I have experienced this with onions, too.

Why does that happen? Is it a bug of the game itself, or a bug of the scenario editor? Is there a workaround to prevent this?
posted 03-29-11 21:54 ET (US)     17 / 31  
There is a bug in Poseidon where the Founding of Troy episode doesn't have a tax office. You can set the tax to whatever but you cannot collect it. Frustrating.
posted 03-31-11 10:20 ET (US)     18 / 31  
@Mierin Seems you reached the walkers limit ...
The market buyer is a destination walker when aiming to the granary , and each of his follower is a DW too ...
When you reach the limit ( specialy when granary is full ) , taking goods launches cartpushers waiting near farms , and the computer is unable to compute pathes for the buyer , his followers and the cartpushers , by lack of free RAM ( 2 DW = 1K Ram ).
You never have the trick at the beginning , as your city is small , and walkers are few !
posted 05-09-11 02:25 ET (US)     19 / 31  
so while playing an adventure i've created (edited, really. adventure was created, played and finished. then reedited with different resource, etc. but same episodes, events, cities). in the edited adventure, when i go back to the parent city after the colony episode, there is no trade building available. the city doesn't show up in the world map as well. i don't know why it happened but i've already played and finished the same adventure, but different resource, etc. please help. thanks
posted 05-09-11 04:33 ET (US)     20 / 31  
Chiz08,ok,you changed your colony's resources,but It doesn't means your colony's trade building was also changed at the same time.because thay are two different things.first,make sure your colony's trade setting is correct,choose your colony in the "edit would map city properties",then set its "sells things" and "buys things",and you must choose "low","med","high" at these goods bottom,If you don't do that,there are no trade building when you come back to your parent city.second you must save your setting,when cilck the "return to main menu" button,choose "yes".third,you must create your adventure again,click the "file" button,then click the "create adventure",choose "yes".I am Chinese,my English is not so good,but I still hope my answer can help you.
posted 05-09-11 16:29 ET (US)     21 / 31  
i've done that. i did everything you said. i don't think the trade settings is the problem. The colony city is not showing at all on the world map after the colony episode...
posted 05-10-11 07:51 ET (US)     22 / 31  
that means your colony is still inactive,maybe that is a game bug,you can check if it is.Can you add one more colony episode when you come back to your parent city after the colony city is not showing at the world map?then you can type "Ambrosia" to next colony episode,then,you can check if your "not showing at the world map colony" is still can be choose.if it still can be choose,that means your colony is still inactive,and that is a game bug,if it can not be choose,that means there is another reason.maybe you can submit your adventure,I can help you to check it.

[This message has been edited by gayforlove (edited 05-10-2011 @ 08:09 AM).]

posted 06-10-11 14:28 ET (US)     23 / 31  
Re chiz08's issue:
Cities have both "active/inactive" and "visible/invisible" states. However, when you change the city type to colony, "visible/invisible" button is disabled, because colonies are supposed to be "inactive", but "visible". But if city was in an invisible state already, it will keep it. So, change city to "foreign", set to visible, change back to colony, problem solved. "inactive" for colony means it will show up as a colony episode and seems to be immune to city status change events (like "city becomes active"). Active colony can be affected by "city vanishes"(invisible and doesn't participate, like chiz's problem) or "city becomes inactive" (can be colonized again) events.


Here's some more information on the "Zeus destroying palace" bug. This actually involves 2 bugs:

1. When a palace is destroyed rather than deleted, the military unit/standards data aren't properly reset, so when palace is rebuilt, some units might have their standards attached to other buildings. This can be fixed by deleting the palace(which properly resets the data) and paying money to rebuild it a second time.

2. When a palace is destroyed all the military units are destroyed, however, soldiers attached to units outside of the city don't seem to be deallocated. Since the units they are attached to no longer exist and don't have the soldiers on their roster, they won't participate in the invasion. They also won't return home, and will just sit there in Limbo. They will continue to take up some of the game's 2000 walker slots. If the palace is repeatedly destroyed while the player is attempting to invade other cities, all the walker slots will eventually fill up with phantom soldiers. Rebuild the palace and the game will attempt to create standards (which also count as walkers) and soldiers for all the new military units. As your existing walkers enter their buildings, their slots will be grabbed by the military units, meaning that the building will no longer have a slot for it to create another walker. Maintainance offices shut down, etc. etc. On the plus side, invading enemy units won't be able to create soldiers either, so will be cheap to bribe. I expect this effect would happen even if the palace was destroyed by disasters, but normally scenario designers don't have good enough aim to wipe out the palace more than once or twice this way.

You can actually create this effect by launching an invasion, deleting your palace, launching the same invasion, and repeating this until you build the palace and no military standards appear. When I tried this, the problem actually cleared up after my depopulated attack forces arrived. I'm not sure if this is because deleting the palace doesn't make the soldiers quite so lost, or if the battle cleared up soldiers en route to that destination.

I'm also not sure if a change in episode will clean out phantom soldiers, but it might. Hera invading and turning all you people into cows seems like it might also clear out the walker list, since she seems to nail everything that's not hostile and not a hero/god/monster, no matter where it is. If somebody wants to experiment further with deleting palace/Hera invading/end of Episode, it would be interesting to hear the results.


Another rarely seen bug happens when returning from a colony. All the terrain goes flat and various buildings may vanish or become corrupt. This has to do with the way the game stores parent city data. Basically, it creates a block of data identical to what it would put in a save file, if you saved right at the end of the scenario. If you save during the colony episode, it will append this block of data to the colony save data. This is rather wasteful, because it stores the events list from the previous episode, which will be replaced by that for the next episode when you return from the colony, and there will be 2 copies of things like the world map. The actual data for the parent save takes up about 3.8 MB. Fortunately, most items in the save file are compressed, which will usually cuts them down to 300-400K, unless you've got a particularly large and complex city. The problem is, the game apparently allocates only 500K to store the compressed save data for the parent city while going to a colony(there's no limit to colony save data size, or parent save data during a parent episode). Anything over that will simply be lost and replaced with 00's. This probably happens more often than people realize, but it doesn't get noticed, because the data at the end of the file is either unused or recalculated when returning to the parent city. However, not too far from the bottom of the save is the height map, which tracks how high each particular square of terrain is. Lose this data and the map becomes flat and all the rocky barriers vanish (Actually, the rocky barriers are stored just below the height data, but they are recalculated upon loading so don't matter).

If one encounters this bug and happens to have a save of the parent city just before visiting the colony, one could go and delete a bunch of stuff from the parent city (like for example the 732 olive trees you planted, each of which counts as a building.). This might shrink the save enough to prevent losing anything critical. If one were feeling particularly adventurous, one could even use a hex editor to cut and paste the missing data into a save of the messed up parent city. However, it would be easy to screw this up which would crash the game, which is bad unless you like watching programs crash and burn.
posted 02-05-12 19:23 ET (US)     24 / 31  
why i can`t build anything in adventure that i created it? it`s a bug? how i can fix the problem? 10x
posted 10-30-14 07:45 ET (US)     25 / 31  
Sorry for posting in an ancient thread, but I figured this was the only appropriate place to ask about it. I've made a large adventure based on the first Atlantis adventure. I've encountered the elevation bug (as mentioned earlier in this thread) when I returned from my colonies, and fixed it by deleting all my olive trees before making a colony.

However, I've now found a new bug that I cannot explain. Some of my normal Townhouses randomly devolve to the second-highest stage, claiming they need more culture, even though they already have enough culture for the maximum. A month passes in-game, and out of the blue all of them instantly evolve back to maximum. Oddly enough, if I load one of my savegames and just let it run the bug won't occur, but if I make a small tweak on one of my (unaffected) neighbourhoods it will show up. The tweak only involves moving some buildings around, but doesn't change how walkers walk their paths in the affected neighbourhoods, or makes me hit the maximum number of walkers. All in all, they keep devolving even when all culture walkers pass the building. I've never seen this problem until now.

-edit- I replaced all game data with a back-up and put compatibility on windows 95. This fixed the bug.

[This message has been edited by Tree Nymph (edited 10-30-2014 @ 05:18 PM).]

« Previous Page  1 2  Next Page »
Caesar IV Heaven » Forums » Zeus: Adventure Design » Zeus / Poseidon - Bug List
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames