You must be logged in to post messages.
Please login or register

Technical Forum
Moderated by Jayhawk

Hop to:    
Topic Subject: Animations gone and Pharaoh crashing at specific time
posted 04-22-20 07:55 ET (US)   
I've tried to find a solution to this here and in many other forums, but I can't seem to find any similar cases so it's difficult to know what advice to follow.

I'm playing Pharaoh and Cleopatra on a PC with Windows 10. It's installed through GOG, and it's installed under C: in the program files. (read this could be an issue). I've resently gotten a widescreen patch. I've had problems with it crashing when starting the game, but fixed that by installing RADvideo. Other than that everything worked fine up until playing Heh.

So on this particular map the first thing I noticed was I could no longer see any production happening. All buildings are active and I can see the thing they produce (trees growing, materials being stored), but the animation showing the production isn't happening, and I see no laborers. There are also no flags on active buildings. The mission was still playable until a certain point (pretty far in) when the screen froze and the sound started looping. This now happens every time, and I think it happens at a certain point in the mission because if I speed the mission up the crash happens faster. I then have to restart my computer. I have also noticed I have people walking around in a spot on the map where there are no buildings or roads. It starts with one man carrying gold and then there are several others in the same spot looping and disappearing, a few moments before the crash.

I've reinstalled the game (but kept the save files) without results. What can I do? Could the problem be the map or the save file and how can I fix that?

[This message has been edited by Annfallet (edited 04-22-2020 @ 08:04 AM).]

posted 04-22-20 08:19 ET (US)     1 / 2  
Hi Annfallet, welcome to Heaven.

Building animations not showing is a rare problem (which does the same thing to C3 at the same time). Rebooting the computer usually fixes it.

The people walking in a spot indicates something is corrupted. Perhaps the corruption causes the crashing. I would load a saved game from significantly before either of those happened and see if you can continue. If you don't have saved games from earlier in Heh, you could start it over (and this time keep several saved games with unique names at least until you finish the mission).

(By the way, my Pharaoh from on Windows 10 frequently gets hung, sometimes in seconds. I have to kill it with the task manager. I haven't tried to fix it, since I have an old computer with Windows 7 that I use for playing Pharaoh. C3 runs fine on either computer.)
posted 04-26-20 07:20 ET (US)     2 / 2  
Thank you Brugle!

This has made me realize I need to save more often, as i rely way too much on autosave history. I would have to go back very far in the game to find anything else. But restarting the mission with the autosave replay works so far, and the animations work (they didn't last time i replayed). Still early in the mission, but hoping for the best!
Caesar IV Heaven » Forums » Technical Forum » Animations gone and Pharaoh crashing at specific time
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames