You must be logged in to post messages.
Please login or register

Technical Forum
Moderated by Jayhawk

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: Running Editor in Windows 10
posted 01-09-17 08:17 ET (US)   
I have tried everything I can think of to resolve this issue, but here's what happens.

I start the editor (in compatability mode XPsp3), the gui appears, but no matter what I try, I cannot get anything else to appear. Where the map should be is simply a black box.

Am I doing something wrong, or has Windows 10 made the editor unworkable?

Thank you.

Tom Fahey
Replies:
posted 01-09-17 08:41 ET (US)     1 / 3  
Hi Tom, I don't have Win10 so I can't assist, but I've moved your post to the Technical Forum where others can help.

To those who can help: He's talking about the Campaign Creator software for the game Emperor: Rise of the Middle Kingdom.

Expand your fun by downloading free custom campaigns for Emperor: Rise of the Middle Kingdom.
Visit Zeus Heaven to expand your knowledge of Zeus and Poseidon.

[This message has been edited by Gweilo (edited 01-09-2017 @ 08:42 AM).]

posted 01-09-17 09:33 ET (US)     2 / 3  
I've just tried loading the Editor (EmperorEdit.exe) on Win10 Pro 64-bit and as far as I can see there were no problems besides a little bit of flickering. I'm using the original fully patched version of the game and I am not using compatibility mode.

My current system is:

Win10 Pro 64-bit (upgraded from Win 7 Ultimate 64-bit)
i7 3930K
16GB RAM 1866Mhz
980Ti (factory OC'ed)
Running from a SSD.

I have not OC'ed anything myself.

Note that as Win10 is upgraded (installed on top) from Win7 Ultimate 64-bit the game was originally installed under Win7 Ultimate 64-bit. I have no idea if that might make a difference. If you have the original CD you could try install DirectX from it as it might contain a directx file that Microsoft does not supply with the current release of DirectX.

"Cats are the only animals that are both uber, pwns and 1337 at the same time." -King Euric
By reading this fine print your soul is now the exclusive property of HeavenGames.

[This message has been edited by PCDania (edited 01-09-2017 @ 09:34 AM).]

posted 01-09-17 13:21 ET (US)     3 / 3  
Works for me. Win10 64bit preloaded machine(I5).

I use compatibility mode Win98(both Emperor.exe and EmperorEdit.exe) so they stays on 1 processor(0). Non-UAC(no admin requirement). I have Emperor setup for 'Windowed Mode' and adjust Editor for largest window size which is less then vertical desktop size(1600x900).
- I use "PlayIntroMovie=no" as the last line of 'Emperor.ini'.
Common checksemperor version 1.0.1.0)
1. should be installed in c:sierra/ not under 'Program Files'. Not normally an issue with Win10, but should be checked.
2. tried to restart(or a shutdown since installing Emperor).
3. tried using 'EmperorEdit.exe' rather then Campaign Creator Button in 'Emperor.exe'.
4. tried without no-CD or widescreen versions.

[This message has been edited by user3 (edited 01-09-2017 @ 02:32 PM).]

Caesar IV Heaven » Forums » Technical Forum » Running Editor in Windows 10
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames