You must be logged in to post messages.
Please login or register

Technical Forum
Moderated by Jayhawk

Hop to:    
Topic Subject: Pharaoh locks up on new installation of Win 7 x64
posted 03-27-15 06:50 ET (US)   
Hi all,
I'd really be grateful of any suggestions that might resolve this problem.

A failed hard drive meant I had to re-install Windows 7 and all my apps. Pharaoh, which had previously played fine on Win 7, now only goes maybe two minutes before it locks up, with whatever sound was playing at the time stuttering like an old scratched CD. The only way I can recover is by using Task Manager to kill the program ... and then it seems that the Pharaoh mouse driver remains loaded (i.e. it continues to move at the Pharaoh speed, not my desktop speed), and I have to reboot my PC to recover.

Some details:
This is a standard installation of Windows 7 Home Premium x64, fully patched. I shut down all other apps (like e.mail and browser) before I launch Pharaoh, and run the game in full screen, not windowed. I've checked that I have up-to-date drivers for my audio and graphics cards. I've set the compatibility mode for the game launcher to Win XP+SP3. And this is the most recent GOG release of the game.

I don't know where to start to troubleshoot this. Other than the hard drive, the other hardware hasn't changed, and everything was reinstalled from the same discs I used before, so it really should be the same, no? (Or am I putting too much trust in Windows? ;-) ) I've tried removing the game and re-installing, but the problem still occurs.

Can anyone please suggest things I can try to see if I can get this running the way it used to?

Many thanks for any help.
posted 03-27-15 16:18 ET (US)     1 / 9  
I would contact the GOG tech support.
posted 05-14-15 11:01 ET (US)     2 / 9  
Yeah, I did, but they only had a list of "standard" things to try for troubleshooting DOSBoxed games generally (like installing the DirectX 9 runtime), I've followed everything they suggested, but it hasn't solved whatever is going on. :-(

I was hoping someone here might have some other kind of tip uo their sleeve.

[This message has been edited by Branais (edited 05-14-2015 @ 11:02 AM).]

posted 05-14-15 15:05 ET (US)     3 / 9  
This seems to be a duplicate thread but in another one you mentioned that you try to run the game in 256 color mode. From what I understand, the game needs to run in 16 bit color mode. Maybe you could try that.

Also, since GOG games are generally tweaked to run on new systems, forcing an additional compatibility mode on top of that might make things worse.

Otherwise, there could be a myriad of potential problems. Try figuring out what might have changed between your two installations and go from there...
posted 05-16-15 04:02 ET (US)     4 / 9  
Yeah, apologies that I duplicated this. I forgot that I had already posted here.

But there have been changes on my system, and the game has had the same problems on both configurations. The difference between the two setups is that I first had to replace my system hard drive, which went from an IDE to a SATA, but was otherwise installed with the same Windows 7 Home Premium from the same DVD. (A legit MS disc; I don't use pirate software.) Then, I was having trouble in PowerDVD that seemed to indicate issues with my graphics card, so I replaced the ageing Radeon HD 5700 with an nVidia GT 740. I did a clean, basic install of the nVidia driver -- my monitor isn't 3D-capable, and I'm not a player of modern games, so I didn't install the 3D support nor the extras like Shadowplay.

The things I listed on the other thread that I had tried were in response to the list I received from GOG support. It was their suggestion that I try 256-colour mode; they also suggested that I try 16-bit mode and that I try enabling DirectPlay under Windows Legacy features; but neither of those is available on my system, and when I asked more than once if that indicated something hadn't been installed or some configuration needed to be changed, I've had no answer to that. So I don't know if they're only going through the motions of support, or if they have no idea and are simply sending me generic replies in the hope that something might work.

In any case, now they've just said, "Oh well, too bad, we can't help." I fnd that really disappointing, but more to the point, it leaves me nowhere to go.

I don't understand why Caesar III and Zeus work fine on this system, but Pharaoh doesn't. I just wish I knew what else to try.
posted 05-16-15 06:26 ET (US)     5 / 9  
There is always a chance your setup file is corrupt. Try downloading it again from GOG.

I'm not that familiar with Windows 7 so I'm not sure whether or how this works on your system but... on Linux you can always run an application through the terminal and if it crashes, the terminal prints out the error message - the exact reason for the crash. Windows 7 must have a command line utility where you can try this. If your game crashes to the desktop, it should be pretty easy. If your whole system hangs up, then the only way I can think of would be to write a script or such for the command line utility, so that it can leave the output in a separate log file.

If you are determined to run Pharaoh, I would give this a shot. Unfortunately, I don't own Windows 7, so I can't help with the particulars of this but you can always search for simple tutorials online. At least you might dig down to the exact reason of your crashes this way.
posted 02-24-16 10:47 ET (US)     6 / 9  
Sorry for bumping this thread, but I found a fix for the game crashing on Windows 7 64bit, at least for me. I'm posting this in case it can help others with the issue.

After looking around, I found a 'fix' where you take the mss32.dll file from a Zeus install and put it in your pharaoh folder (overwriting the existing file). This didn't work for me though. I checked windows event logs and found Pharaoh kept crashing in MP3DEC.ASI. After looking at Zeus's files, I saw that file there too. So I took MP3DEC.ASI from Zeus and put into Pharaoh. It seemed to work. 3 hours of gameplay so far and no crashes.
posted 10-25-16 03:33 ET (US)     7 / 9  
I'm having this trouble too, but I don't have a Zeus game. Can you possibly upload that file?
posted 02-12-17 09:53 ET (US)     8 / 9  
I too am having issues with Pharoah/Cleo crashing after a few minutes. This is my original box version (Great Empires Collection 2000). It used to play fine on Win 7 64 bit, but haven't played in a couple years. Now I want to play and it locks up. Any suggestions from all you Game Gods?

Of course I have a life!!! I build and rule mighty empires. With out me all these peeps would starve and chaos would reign.
posted 03-30-18 20:46 ET (US)     9 / 9  
I'm having a similar issue myself. All of the others play fine - Emperor, Caesar and Zeus. But Pharaoh (and Cleo) will freeze after a time in game. There has to be a glitchy file in there somewhere similar to what was found previously (that MP3DEC.ASI that was found earlier in this thread). Any ideas guys and gals?

There's no place i'd rather juggle
Caesar IV Heaven » Forums » Technical Forum » Pharaoh locks up on new installation of Win 7 x64
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames