You must be logged in to post messages.
Please login or register

Caesar IV: Game Help
Moderated by Gweilo

Hop to:    
Topic Subject: Caesar IV 1.2 patch
posted 01-17-07 18:18 ET (US)   
The patch is finally out. Get it at the Caesar IV official site.
posted 01-17-07 19:11 ET (US)     1 / 26  
Woohoo! Happy New Year everyone!

The list of fixes is here

Thanks Ogedei.

:Edited January 2009:

The original download link redirects to Activision, but the patches are now available from our downloads section.

The correct patch for the US version of the game is caesariv_update_en_10-11_12.exe. The patch for the UK/International English version is caesariv_update_en_10_12.exe.

[This message has been edited by kach (edited 01-28-2009 @ 02:59 PM).]

posted 01-17-07 20:28 ET (US)     2 / 26  
My version is 1.01.. international, english language.. will I need 1.2 ?

are all savegames useless?? so I need to play everything again?

[This message has been edited by mhusoy (edited 01-17-2007 @ 08:35 PM).]

posted 01-17-07 21:11 ET (US)     3 / 26  
1.2 fixes many of the critical bugs that were present in 1.1, so of course you will need the patch. I'm not entirely sure if save games are rendered useless; they are for online play, however.

EDIT: OK, so I've tried installing the patch and it doesn't work. I think that they might have accidentally uploaded the wrong version. Let's see if others are having problems and if this is the case.

[This message has been edited by Ogedei (edited 01-17-2007 @ 09:30 PM).]

posted 01-17-07 22:02 ET (US)     4 / 26  
Great! Hopefully I'll be able to get back to Alexandria. That trade route bug was driving me crazy!
posted 01-17-07 22:26 ET (US)     5 / 26  


Added INI option for disabling weather (Open caesariv.ini in a text editor. To disable weather, change the line "Weather 1" to "Weather 0" in the caesariv.ini file. If the "Weather" setting is not in the INI, add it manually after installing the update)

Thank you thank you thank you thank you thank you thank you thank you!!!!!!!

posted 01-17-07 22:56 ET (US)     6 / 26  
I just installed the English 1.1 to 1.2 patch. No problems. My 1.1 saves load fine.

[This message has been edited by kach (edited 01-17-2007 @ 10:58 PM).]

posted 01-18-07 02:02 ET (US)     7 / 26  
OK, so it seems that the link on the News page is actually for 1.0 to 1.2. If you have 1.1, you'd have to go to the Downloads page and get the 10-11_12 file.
posted 01-19-07 10:07 ET (US)     8 / 26  

If using US version 1.01, don't patch to 1.2 yet, there was a 'screw-up' with the patches...

See post no. 43 here:

I did, and now can no longer even sign-in to the online community....

posted 01-19-07 15:31 ET (US)     9 / 26  


I did, and now can no longer even sign-in to the on-line community....

I just tried it, and it worked. I did have a new prompt from the firewall, and I had to re-allow Caesar IV to access the internet.

posted 01-19-07 23:31 ET (US)     10 / 26  
Can some tell me how I find out if I have US or UK game - Purchased in Austrlia.tia
posted 01-20-07 00:36 ET (US)     11 / 26  
Hi Madness. I bought mine in Australia. It is the US version. The box looks different for the International English edition. Check out the different boxes for US and UK. Which one do you have?
posted 01-27-07 21:39 ET (US)     12 / 26  
Wow, the patch was released while I was away eh. I was just reading the list of fixes:


- Added INI setting where build buttons will close after choosing a building to build (Open caesariv.ini in a text editor. To enable feature, change the line "CloseBuildMenus 0" to "CloseBuildMenus 1" in the caesariv.ini file)
- Added INI option for disabling weather (Open caesariv.ini in a text editor. To disable weather, change the line "Weather 1" to "Weather 0" in the caesariv.ini file. If the "Weather" setting is not in the INI, add it manually after installing the update)

These sure will come in handy for a lot of people.

posted 01-30-07 16:20 ET (US)     13 / 26  
Saw this in patch 1.01 and it's in 1.2 patch, too:

Checking the labor resources - Carthago

Total Plebs Needed: Have - 3504 versus Need - 3544

Unemployed Plebs: 56

Always seems be in industry that reads low in the 'Have' column. However, the plebs are available, at least when I place a new industry, farm, or raw material camp they fill the vacancies.

Also, while playing Carthago, I missed a request of wool, but it gave me another 4yrs 6 months to fill it. However it never showed up on the Imperial request list. I would think it should have been listed as an outstanding request. Even 4 yrs out...which seems a bit much - mho.

Lost my HD a few weeks ago, after re-loading C-IV, I went directly to the new patch - English version - without any problems. Overall I'm quite happy with the patch, especially being able to turn off the weather.

posted 06-30-07 21:46 ET (US)     14 / 26  
i have just installed this game and when i go to play it all i have is a white screen but, i can hear music, ads etc.. i have installed latest versions of DirectX and newest patches. what is the problem??
posted 06-30-07 23:58 ET (US)     15 / 26  
Hi workcrow, welcome to the forums.

It sounds like it might be a video issue. If you post here in the technical forum, angel PCDania will probably be able to help you.

Be sure to mention that the game is Caesar IV, and mention your computer specs too.
posted 12-23-07 00:05 ET (US)     16 / 26  
I can't seem to download the patch at all. I've tried in both IE and Mozilla. If I try to click on the link I get a webpage not responding type error (both browsers). If I right click on it to save target as it doesn't save (in IE I get an error while saving and in Mozilla it appears to save but doesn't appear in the location).

I tried turning off my antivirus...turned off pop-up blocker (not that I suspected that, but I was trying everything I could think of).

Does anyone else have any other suggestions?
posted 12-23-07 02:19 ET (US)     17 / 26  
Do you mean the US version 1.2 patch?

When I go to this page and click on 'download now' I get the usual dialog saying 'Do you want to run or save this file?' Do you mean this is not happening?
posted 12-23-07 03:14 ET (US)     18 / 26  
Yes, Kach...that is exactly what I mean. I don't get the run or save dialog box. But, apparently, it sounds like it's just me...which is a bummer.
posted 12-23-07 04:20 ET (US)     19 / 26  
It's looks like you cannot connect to the ftp site for some reason. Try the technical forum. Angel PCDania is sure to have a few suggestions.
posted 01-17-08 22:45 ET (US)     20 / 26  
The last post is a year old. Is anyone still moderating the forum?
My game keeps crashing. I'm playing Amida scenario on normal, and once my population starts to build everything collapses and the game crashes. I keep starting over but it's getting frustrating.
posted 01-17-08 22:56 ET (US)     21 / 26  
Hi karenusXXI. Sorry to hear the game is crashing, Caesar IV can be quite picky about computer specs.

If you post in the city building technical forum, you will catch the eye of the technical folks and get some help. Be sure to mention your system specs and that the game is Caesar IV.
posted 01-04-21 04:05 ET (US)     22 / 26  

[This message has been edited by Gweilo (edited 01-04-2021 @ 08:26 AM).]

posted 12-19-21 07:20 ET (US)     23 / 26  
Having read most of the posts, my personal advice is, DON'T install the patch. The game works perfect for me. I've even got to the end. Nicomedia and Colonia Agrippina.
posted 03-14-22 02:44 ET (US)     24 / 26  
how can I avoid the game crash any idea Guys
posted 04-06-22 11:42 ET (US)     25 / 26  
Its also crashing for me, any help would be nice
posted 04-06-22 15:50 ET (US)     26 / 26  
I'm sorry your games crash. I play the GOG version on Win 10 without problems.

If you do not have the GOG (or Steam) version, it may be worth buying it. It's not very expensive even when it is not on sale.
Caesar IV Heaven » Forums » Caesar IV: Game Help » Caesar IV 1.2 patch
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames