You must be logged in to post messages.
Please login or register

Children of the Nile: Game Help
Moderated by Jayhawk, kach

Hop to:    
loginhomeregisterhelprules
Bottom
Topic Subject: CotN bugs – version 1.1
posted 01-03-05 23:09 ET (US)   
I have come across a few game play issues that don’t seem to be covered by the forums or FAQs on the Tilted Mill site. It’s also hard to find the bug threads in the technical forum as the threads there are mostly about video card issues. So this thread is for bugs.

Please add to this thread if you wish. You may want to check game play topics described in the TM FAQs first, to see if it is just ‘user error’. And it might be a good idea to keep the saved game in case the people at TM need to look at it.

My list so far:

1Pause status lost when message window is closed
2Workers get stuck on the flood plain
3Statues never delivered to temples

Replies:
posted 01-03-05 23:12 ET (US)     1 / 20  
Pause
If you open the message window with the game on pause, when the window is closed the game is set back to ‘un-paused’, and you have to click the pause button twice to stop play again

Stuck workers
This has been mentioned fairly often. I managed to get several farmers and a scribe stuck in shallow water beside the floodplain. They were stuck quite close to a barge landing but I don’t know if that was significant. I moved the scribe with a bush but he kept returning to his original position. Deleting the barge landing had no effect. Deleting the scribe’s house was the only solution.

Statues
If you build a temple across the river from your basalt statues BEFORE you place the barge landings, the labourers will never deliver the statues. I don’t know if this happens when you are mining statues but it certainly happens when you are importing them. In the end, I had statues delivered to both sides of the Nile and subsequent temples and statues had no trouble, but the temple I built and dedicated before I placed the barge landing never received a statue. The overseers would cross the river and stand in the temple for a while, but the labourers never left home. The solution seems to be always build the barge landings first.

posted 01-04-05 04:25 ET (US)     2 / 20  
These issues have been resolved. If you do encounter them, check again if you really updated your game, perhaps something went wrong. Otherwise, submit them!

Another bug:

If you have a working weaponsmith/armourer/kopesh-smith/chariot maker with supplies and you change it to something else, the numbers in your resource overview will no longer be accurate. However, there should be nothing wrong with your actual supplies.

posted 01-04-05 16:30 ET (US)     3 / 20  
Re: Statues. I can tell you that it does occur when quarrying statues, as I'm finding out in Henen-Nesu. And it isn't just the barge landings that need to be built. I had them done, but only one of the two barges was built when my cult temple finished. It and two other temples built after the last barge was in place along with a statue base are still waiting for stautes to arrive. Even deleting and rebuilding the cult temple didn't cause the statues to be delivered. Two temples and a small and large statue on the same side of the river as the quarry did receive them though. Unfortunately, it doesn't look like basalt is available from an outside source in Henen-Nesu. Also unfortunate I'm a very slow player, so my people are demonstrating yearly because the cult temple doesn't have a statue.
posted 01-04-05 17:49 ET (US)     4 / 20  
It is most likely something else causing that particular statue to be "stuck" somewhere, after it had already been "reserved" for the cult temple. I know that you can finish statues that have been started before the barges are available, in fact I've done this fairly often. I will usually have my Cult Temple in place for general worship needs well before I have the ability to get the statue to it...
posted 01-04-05 21:24 ET (US)     5 / 20  
I had dedicated my temple (it wasn't a cult temple). Maybe it would have been OK if I hadn't done that. I did try resetting the dedication to none, and then reselecting the god about a year later but still nothing happened.
posted 01-05-05 07:48 ET (US)     6 / 20  
Hmm, any chance you still have a save you could post of this occuring? I always "dedicate" my temples as soon as I place them even if the statue won't actually be delivered (or even available) for some time after completion, so I don't think that is the problem. It might however just be an issue with temples, and not cult temples (I never use temples except for asthetics, shrines work fine unless the city has a patron deity)...unlikely, though possible, as they use different sized statues.

[This message has been edited by Raccoon_TOF (edited 01-05-2005 @ 07:49 AM).]

posted 01-05-05 22:47 ET (US)     7 / 20  
I have a save, but I don't have a way of posting it. I could email it to you if you want. The issue though also affects statues, since I placed a base that never received its statue. (The save doesn't have the base in it though.)

Another bug: a person trapped inside their own home trying to buy goods. I've had a brickmaker's wife trapped in her house trying to barter for baskets, food in hand. Also, I've had nobleman stuck in his townhouse trying to shop for goods. Only active solution is to delete the house. Or wait until dissatisfaction drives the family out. Nobleman actually became unstuck to go complain.

posted 01-05-05 23:31 ET (US)     8 / 20  
You can submit it as a "completed city" here on the HG CotN forums at this link: http://cotn.heavengames.com/downloads/submit.php

You will need to sign up with a different user name over in the download section though before you can submit (just add an _ or a number to your name should work fine) because the download section uses a different database than the forums do. Let me know here when you have it posted and I'll go take a look at it.

Alternatively, you can create a help post over on the main Tilted Mill forums and attach the file there...

posted 01-06-05 15:36 ET (US)     9 / 20  
I have a saved game, but should I submit it if JimMRooney submits his? Do I post it at TM in the technical forum?

Security complaints

Another problem I have found is with the administration report. Clicking on the security complaints never highlights the buildings with security complaints. So you cannot tell who got mugged or who was raided.

Cargo drop off

Also, I don't know if it is a bug or a feature, but only four kinds of items are visible in the inventory for a raider or a cargo drop off point. In one game I thought I'd lost my large statue but it was in the cargo drop off, just not showing.

posted 01-08-05 09:46 ET (US)     10 / 20  
posted 01-08-05 11:20 ET (US)     11 / 20  

Quote:

Another problem I have found is with the administration report. Clicking on the security complaints never highlights the buildings with security complaints. So you cannot tell who got mugged or who was raided.


I noticed this one too. However, clicking on the icon before the security text does highlight all buildings with security problems (at least it did in v1.1, I still have to install the 1.2 patch).

Quote:

Also, I don't know if it is a bug or a feature, but only four kinds of items are visible in the inventory for a raider or a cargo drop off point. In one game I thought I'd lost my large statue but it was in the cargo drop off, just not showing.


This is a feature, not a bug What I do, is just build enough (dedicated) drop-off points and keep at most 3 types of goods in them.

Angel Pecunia | HG Downloads programmer and techie
Caesar IV Heaven | Children of the Nile Heaven | Citadel of Poseidon (Zeus/Poseidon) | The Great Wall (Emperor)
posted 01-08-05 14:15 ET (US)     12 / 20  
Ah, thanks for the suggestions Pecunia.

I guess we won't need this thread any more. Lets see what happens with version 1.2.

posted 01-08-05 14:16 ET (US)     13 / 20  
I think we still need this thread, we only have to update it to version 1.2 if new bugs pop up .
posted 02-25-05 13:53 ET (US)     14 / 20  
Just a couple of issues I had (now finished all levels in campaign) using patched V1.2:

Administration Report - Funery services - Tombs

On every scenario this problem was the same. The figure always showed 0/22 or 0/15 - i.e. No. of available tombs/tombs built (the 2nd figure was irrelevant), despite my having several tombs available (over and above the requirements for nobles/royal family/pharoah.

In Pi-Rameses only - Resource Report vs World Map

In this last scenario a strange thing re-occurred often. Say a city required 750 food (as well as other things) to open. While my Resource Report may have shown 0 food available, the world map showed I had, say, 1500 food available, and thus allowed me to open places despite not having enough food. This problem didn't occur in any other cities.


WendiM (alias Wendoolicus)
Improve your vocabulary... for words are the tools of thought!
posted 03-04-05 14:19 ET (US)     15 / 20  
Hi all,

This is for 1.0 Men-nefer (don't know whether somebody else got this too or this has already been tackled, but here goes...

1. Bricks/Food indicator ("Z") was showing ~700+ Bricks/9000+ Food but individual resource inventory was showing ~13 Bricks (also, the rate of delivery of bricks to the fresh mastabas was appropriate for ~13).

2. After the grand pyramid was built, the fine & the usuaal limestone inventory showed about 200-300 more pieces than I had just at 99% completion (not importing). Also, these bloated indicated figures were not able to support further projects (had the same problem when I made grand pyramid in Nekhen after victory).


Anything that hurts gameplay will be blindfolded and shot.

[This message has been edited by Andyblast (edited 03-04-2005 @ 02:28 PM).]

posted 03-04-05 17:00 ET (US)     16 / 20  

Quoted from Wendoolicus:

Administration Report - Funery services - Tombs

On every scenario this problem was the same. The figure always showed 0/22 or 0/15 - i.e. No. of available tombs/tombs built (the 2nd figure was irrelevant), despite my having several tombs available (over and above the requirements for nobles/royal family/pharoah.


This isn't really a bug; it just doesn't work the way you'd expect it. Any time the tomb is reserved for someone (Pharaoh, royal family or nobles), the game sees it as not available whether it is occupied or not. If you switch it to anyone, it will show up as available in the report when it is empty.
posted 04-10-05 13:29 ET (US)     17 / 20  
What is the best way to tell which version of the game you are running? I downloaded and ran the 1.2 patch, but still believe my version is 1.1 (looking through the program files under My Computer). Is it not listed on the game somewhere while you're playing? Thanks for any and all help.
posted 04-11-05 04:22 ET (US)     18 / 20  
Well, you got me wondering there! The version of my CotN.exe is 1,1,6,119 and I have the 1.2 patch installed.
posted 04-12-05 01:28 ET (US)     19 / 20  

Quoted from Jeff Fiske - Design Director of TM:


There is no version difference noted between 1.1 & 1.2 if you right click on the executable and look at details.

Thus you have to look for other evidence for what version you have.

The date of the EXE should be from January, 2005 if it is version 1.2.

OR

If you have *.db files from Jan 3rd, or later than Nov 11th, then you have version 1.2

DB files are located by default here:
C:\Program Files\Tilted Mill\Children of the Nile\data\db

Hope this will help you find your version .

posted 06-29-13 00:54 ET (US)     20 / 20  
In the 3rd tutorial when it tells you to build 4 weapon makers it wont go any farther than that & I cant finish the tutorial. Can this be fixed?
Caesar IV Heaven » Forums » Children of the Nile: Game Help » CotN bugs – version 1.1
Top
You must be logged in to post messages.
Please login or register
Hop to:    
Caesar IV Heaven | HeavenGames