You must be logged in to post messages.
Please login or register

Caesar IV: Game Help
Moderated by kach, Gweilo

Hop to:    
Welcome! You are not logged in. Please Login or Register.7 replies
Caesar IV Heaven » Forums » Caesar IV: Game Help » Trade port not working
Topic Subject:Trade port not working
posted 12-11-17 12:51 ET (US)         
Hi all,

Hopefully you can help me with an enigma...

My trade port isn't working.
- I have plenty of goods;
- I am not stockpiling;
- The port has full employment;
- The port is set to 'sell';
- The port has stock to sell;
- The trade route is open (not suspended);
- The port is reachable for ships (the port right next to it works);

...I think I've covered every possible problem, but there are no ships coming to this port. Did I forget something?
I've noticed this type of trader behaviour before, but usualy when you suspend and then open the trade route, or stop selling and then start again, the trader will come again. But not this time. I've reloaded the scenario, I've reloaded the game. Haven't tried rebooting Windows yet, but that's not gonna solve it :-)

Anybody have a clue? Many thanks in advance!

Greets, Flu
posted 12-11-17 13:22 ET (US)     1 / 7       
Hi Fluwyn

Just to be clear, on the world map, the trade port shows 'suspend' not 'resume'. Is that right?

Which scenario are you playing?
posted 12-13-17 12:48 ET (US)     2 / 7       
Hi Kach,

Thanks for responding!

Yes, it says 'suspended' - so that means that it is open, and pressing the button will suspend it.

I've had this problem in numerous scenarios, but this particular time was in Nicomedia.

Greets Flu.
posted 12-15-17 03:46 ET (US)     3 / 7       
I've searched through some of the old posts and I notice that sometimes it takes 12 months before the first trader visits. Could that be the problem?

Does deleting the trading port and rebuilding it fix the problem?
posted 12-19-17 17:08 ET (US)     4 / 7       
Hi Kach,

No it was definitely longer than 12 months. I have not destroyed and rebuilt the port. I tried just about everything else, lol
Keith Heitmann
posted 12-31-17 04:01 ET (US)     5 / 7       
It may be that even though it looks like the route to the port is "open" in appearance, if the port is in a narrows between the mainland and island, the game may not see that route as navigable. You may have to move the port.

Community Moderator for the former Sierra for Caesar III, Pharaoh/Cleopatra, Zeus/Poseidon, Emperor, Lords of the Realm II/III, World in Conflict.
Core beta tester for Pharaoh, Cleopatra, Zeus, Poseidon, Emperor, Lords of the Realm III, and all their patches.
Core beta tester for Tilted Mill's Children of the Nile. Selected as a Tilted Mill "Luminary".
Beta tester for Civilization III: Conquerors by Sid Meiers, A Force More Powerful by BreakAway Games, and Arabian Lords for Breakaway Games.
posted 12-31-17 13:59 ET (US)     6 / 7       
Thanks Keith, I hadn't thought of that.
posted 04-17-19 01:31 ET (US)     7 / 7       
Spam. Link removed.

[This message has been edited by kach (edited 04-17-2019 @ 01:52 AM).]

You must be logged in to post messages.
Please login or register

Hop to:    

Caesar IV Heaven | HeavenGames