You must be logged in to post messages.
Please login or register

Emperor: Game Help
Moderated by Gweilo

Hop to:    
Welcome! You are not logged in. Please Login or Register.134 replies, Sticky
Caesar IV Heaven » Forums » Emperor: Game Help » Emperor Patch - Bugs Report
Bottom
Topic Subject:Emperor Patch - Bugs Report
« Previous Page  1 2 3 4 5 6  Next Page »
Ben The Vizier
Pleb
posted 08-10-03 04:44 ET (US)         
Hi!

I have installed the Emperor patch, and I have started playing the Han campaing. I didn't go much deeper into it, but so far there are two things I noticed were not corrected.

AGRICULTURE PANEL

If you load any city before starting a new scenario, the Agriculture Panel will tell you that the food imports can sustain, for example, 7546 people, i.e., the amount of food your were importing in the last scenario.

HOUSING

If you save your game with unoccupied houses, exit that game and reload it again, the unoccupied houses will turn into Huts or some other kind of housing I can't remember at the present.

-

Those were the only bugs I noticed so far. If you notice more, head over here to post more.

Ben The Vizier

AuthorReplies:
TuShaWuJin
Pleb
(id: shaun1)
posted 12-30-06 06:50 ET (US)     76 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:29 PM).]

nickee
Pleb
posted 12-30-06 10:19 ET (US)     77 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:29 PM).]

nickee
Pleb
posted 01-02-07 04:59 ET (US)     78 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:30 PM).]

Gweilo
Angel
posted 01-02-07 10:38 ET (US)     79 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:30 PM).]

nickee
Pleb
posted 02-07-07 08:51 ET (US)     80 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:30 PM).]

Gweilo
Angel
posted 02-07-07 11:42 ET (US)     81 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:31 PM).]

TuShaWuJin
Pleb
(id: shaun1)
posted 02-07-07 20:23 ET (US)     82 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:31 PM).]

nickee
Pleb
posted 02-08-07 08:26 ET (US)     83 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:31 PM).]

Gweilo
Angel
posted 02-08-07 11:27 ET (US)     84 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:31 PM).]

joshofet
Pleb
posted 02-08-07 15:22 ET (US)     85 / 134       

[This message has been edited by Gweilo (edited 02-11-2007 @ 12:32 PM).]

mirastic
Pleb
posted 02-11-07 06:51 ET (US)     86 / 134       
Hi all.

I am using Windows Vista Ultimate with the latest updates. My Pc is 2.6 @ 3.05 P4 HT, 1 Gb ram, ati 9700 pro, 250 gb hdd etc. I was using the Emperor with the latest update 1.0.1.0 on WindowsXP Pro but after I switched to Vista I found some bugs. One of the major bug is that the writings dont fit with the action that actually do. For example if some foreign embassor comes to my city, it used to say permit or something like that but now i have to click 'decline' in order to permit embassor. Another such bug could be found when an enemmy army enters your city. It used to say surrender, bribe or fight for city ( I couldnt remember the exact names) anyway but it now says permit, scheucdle and cith_name. Also there are some problems when sending a spy to another city, it is nearly impossible to send a spy for the right intensions to another city. There are some other too but those are the major ones that really annoyed me. I hope you guys can find a solution asap.

TuShaWuJin
Pleb
(id: shaun1)
posted 02-11-07 07:24 ET (US)     87 / 134       
Try removing via Control panel 'Add/Remove Program' and reinstaling Emperor and patch. This type of data error in Emperor happens rarely.
Not sure what about any Vista upgrade issues, but recommend that the C:\Sierra\EmperorROTMK folder should NOT be compressed or encrypted.

The techies that may be able to help with any Vista issues can be found in the Technical Forum

[This message has been edited by shaun1 (edited 02-11-2007 @ 07:40 AM).]

DEADEYES
Pleb
posted 09-09-07 07:13 ET (US)     88 / 134       
i've got a problem when playing multiplayer: i can't control the speed of the game, it's crazy, out of my control. My version is 1.0.1.0, any suggests here?
Gweilo
Angel
posted 09-09-07 08:16 ET (US)     89 / 134       
You won't be able to. In multiplayer, the game automatically synchronizes all the players to the same gamespeed. It's not a bug, btw.

Expand your fun by downloading free custom campaigns for Emperor: Rise of the Middle Kingdom.
Visit Zeus Heaven to expand your knowledge of Zeus and Poseidon.
CajNatalie
Pleb
posted 06-12-08 19:59 ET (US)     90 / 134       
I've got a few bugs with Emperor 1.0.1.0 (or whatever the patch ish), which appeared while I was playing the first mission of the Zhao dynasty, where you have to build Hao up with a few Humble Compounds, an ally, and 3 vassals.

Eventually, after I opened trade with Wu, they asked for 400 bars of bronze.
I didn't have any storage for bronze - it was just going straight from the smelters to the forgers and bronzeware makers, since I like to make enough industry to consume all raw materials that I produce.
So... I made a new warehouse, and set it to accept bronze.
I then told my Ministry of Commerce to stockpile bronze, and watched as bronze rapidly piled up in the warehouse to 400 within seconds.
However, I only showed as having 0 Bronze... I waited until next month, and it was still 0... even though I had way more than the required 400 by that time.
I noticed the Ministry of Commerce kept on flicking from 0 to 1 every time a new delivery arrived in the warehouse, but he quickly fixed the books to say 0 again within a split second... thus keeping the figure at 0.

I turned off stockpiling, and then turned it on... but that only made things more confusing, as a warehouse deliveryman appeared the moment I stopped stockpiling, taking 400 bronze from the warehouse to deliver to some forges or something... oddly enough, the Ministry of Commerce reported -4 for a split second, before quickly correcting himself to 0, which was still incorrect anyways, since I had half a warehouse full of bronze left. o.O

I saved and loaded the game... and all of a sudden I had my bronze figures correctly displayed, and the Ministry of Commerce denied all accounts of there ever having been an error in the books.
So now thanks to this, I was successfully able to fulfil Wu's request.

---

A second problem was a sudden inability to bring up city trade reports in the world map. I would click on a city, and I would only see the 'click on a city to see etcetera...' message in the side...
(before I get the idiot's question, YES I was clicking on the cities correctly - multiple times XD)
I saved and reloaded to find the problem not fixed.
I closed down Emperor and then started up again while loading the last save, to find the problem magically fixed; allowing me to once again click on cities to bring up their reports.

[This message has been edited by CajNatalie (edited 06-12-2008 @ 08:03 PM).]

joshofet
Pleb
posted 06-13-08 05:45 ET (US)     91 / 134       
Sounds more like a problem with your installation than a bug of the game. Not every single malfuction of a program is a bug, only if it is reproducible and important for the game itself it might be identified as such. If the problem does not resurface, I would not worry about it. If it does, reinstall the game. If that does not help, refer to the Tech forum.

Please try to be polite, we are just trying to help you, and we have to do with the information you are supplying. Maybe sometimes we ask for the obvious, you would be surprised how often the obvious is not at all that obvious to other parties involved. I do not think the suggestion that any of the parties involved is an idiot is quite appropriate, even if it was meant in jest.
TuShaWuJin
Pleb
(id: shaun1)
posted 06-13-08 07:03 ET (US)     92 / 134       
To avoid delivery of stockpiled commodities; 'Pause'(shortcut toggle key 'p') the game while you 'unstockpile' the commodity and fulfil the request.
Misaligned graphics is a rare occurance that can cause your problem. The solution is to save & restart Emperor(as you did), if it persists or becomes a common occurance then try defragmenting your harddrives. Uninstall/reinstall is the last option. If your still having simular data corruption issues, with other games too, then it may be a hardware issue(overheating processor or RAM).

[This message has been edited by shaun1 (edited 06-13-2008 @ 07:22 AM).]

CajNatalie
Pleb
posted 06-13-08 08:00 ET (US)     93 / 134       
@joshofet: You make a huge misunderstanding.
By 'idiot question,' I mean the question that designates me as the idiot. However, as I stated, I avoided said designation in that instance. Considering I have no problem with tentatively calling myself an idiot within reason, I see no problem.
Honestly, I'm surprised at your reaction, because if anything it's offended -me-, because now I feel like my words have been twisted (regardless of your intention, I'm just stating how you've made me feel, by the way). o.O

@shaun: With the stockpile thing, I kept it unpaused on purpose for the very effect of observing a 'depletion' of stock, to see what the game would do about it, considering it would be depleting from zero, if you understand? Sorry I wasn't clear about that point. :3

Anyways, thank you for the words, both of you... I guess these weren't really 'patch bugs' I suppose. D=
joshofet
Pleb
posted 06-13-08 09:45 ET (US)     94 / 134       
I understood you perfectly CajNatalie, what you did miss is that there simply is no such thing as an idiot question, just people who do not understand something and others who are trying to help, and they have to get by with the restricted communication of written text.

Hope you get your problem solved.
hwang ta ti
Pleb
posted 11-25-08 04:34 ET (US)     95 / 134       
I want to ask why I can`t built monument? no one monuments or even guilds I found in monument tab in open play. In open play path, no path about monument had appear. And I can`t built city gate. Each I tried to built it a message ``built on clear land`` appear, but no clear land allow to built this building. How to fix this problem
Gweilo
Angel
posted 11-25-08 06:59 ET (US)     96 / 134       
Welcome to Emperor Heaven, hwang ta ti.

Do you have the game patch installed? You will need it installed before you can put monuments in an Open Play game.

Expand your fun by downloading free custom campaigns for Emperor: Rise of the Middle Kingdom.
Visit Zeus Heaven to expand your knowledge of Zeus and Poseidon.
TuShaWuJin
Pleb
(id: shaun1)
posted 11-25-08 12:31 ET (US)     97 / 134       
Activision has taken over VU/Sierra so many of the patch links are not working. Sierra's FTP works for now, but many users are not familiar with FTP.
ftp://ftp.sierra.com/pub/sierra/emperor/

Have fun editing the update links for Emperor:RotMK and previous games.

The Military Gate requires a 5x3 footprint without rocks or trees(trees can be deleted, rocks can't). You first need to build a Road and Military Wall like this. The greenish grassy areas being clear of any rock or trees. Then you can place the Miliatry Gate over the road/wall section and it will turn to a green footprint.

Legend

[This message has been edited by TuShaWuJin (edited 11-25-2008 @ 12:58 PM).]

hwang ta ti
Pleb
posted 11-26-08 04:49 ET (US)     98 / 134       
where I can get that patch, and what is patch? how to know it is it a file? how it looks like?
Gweilo
Angel
posted 11-26-08 06:55 ET (US)     99 / 134       
We staffers are discussing how you can get the patch now that Sierra pulled the plug on their download, stay tuned.

Meanwhile, you can use TuShaWuJin's explanation to build a city gate.

Expand your fun by downloading free custom campaigns for Emperor: Rise of the Middle Kingdom.
Visit Zeus Heaven to expand your knowledge of Zeus and Poseidon.

[This message has been edited by Gweilo (edited 11-26-2008 @ 06:55 AM).]

TuShaWuJin
Pleb
(id: shaun1)
posted 11-26-08 13:47 ET (US)     100 / 134       
Emperor Patch: English
Emperor Patch: French
Emperor Patch: German
Emperor Patch: Italian
Emperor Patch: Spanish
Choose the language version that you have as you can't change languages. Choose 'Save' and save the file to your Desktop to be run at a later time or 'Run' if you want to apply the patch immediately.
I recommend 'Restarting' your computer after successfully applying the patch before trying to play Emperor.

almost forgot we can use HTML here

[This message has been edited by TuShaWuJin (edited 11-26-2008 @ 03:48 PM).]

« Previous Page  1 2 3 4 5 6  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Caesar IV Heaven | HeavenGames