You must be logged in to post messages.
Please login or register

Zeus: Adventure Design
Moderated by Gweilo

Hop to:    
Welcome! You are not logged in. Please Login or Register.23 replies, Sticky
Caesar IV Heaven » Forums » Zeus: Adventure Design » Colonies settings
Topic Subject:Colonies settings
posted 12-29-02 09:30 ET (US)         
We have another problem. We are trying to set up an event to make a colony active. Checked in the existing adventures and used the same settings in our event but our colony won't come up. We don't get the box on screen that allows us to go to the colony and work on it. We set up an event that makes our other colony gives us fleece every so often and that works fine. But we don't seem to be able to make that one visible either. What are we doing wrong.
posted 12-29-02 11:50 ET (US)     1 / 23       
It sounds mighty like your city naming notes are incorrect.

While Emperor uses the actual city names, thank goodness, you have to depend on your notes for Zeus as the names aren't used in the event setups. Check very closely that you're starting with city ZERO, and verify your city numbers.

Extend your grasp of the Empire at Serpentineum
posted 12-30-02 08:15 ET (US)     2 / 23       
Couple things you can check for in the editor settings.


We don't get the box on screen that allows us to go to the colony and work on it.

If you are planning to go to your colony after the FIRST parent mission, the first city selection would be COLONY.
So you would have, COLONY, PARENT VICTORY as an example. Always remember that the mission selection in the top portion of the editor refers to PARENT city. So, since you will always start in the PARENT city, if you wanted to go to a COLONY immediately after the first mission, it would be listed FIRST.

If that part is set up right. Check to see what you have scripted in the first parent mission before you are supposed to go to the colony. DO NOT SCRIPT AN EVENT IN THAT EPISODE TO MAKE THE COLONY ACTIVE. That will be done automatically when you are playing. Also do not have the city appearing or disappearing at all. All of this will happen automatically with the Colony once you have visited it.

Hope this helps. If not, send the files over to me in a zip format and I will take a peek for you.

Have fun

One day I will get used to the fact that life just happens. Until then, I will pretend that I serve a purpose.-- DarkLord
posted 01-17-03 18:37 ET (US)     3 / 23       
I am also having trouble with colony episode settings. This is my first time to make an Adventure so I thought I'd make it simple and just have 3 episodes: Parent, Colony, Victory.
The first episode plays fine but when it's time for the Colony episode to come on, I get Victory and the third Parent episode not the Colony episode. I've checked my city numbers. They're fine. When I put the setting of Colony as the first episode up top, then the Editor won't let me "Create Adventure". It says: "Wrong Number of Colonies - found 1, expected 0 - OK?" When I have Parent as the label for the first episode I can create the Adventure but that's when no Colony episode occurs. Any help you could give me would be appreciated. Thanks.
posted 01-18-03 00:38 ET (US)     4 / 23       
There must be something in the air... this is the third colony question I've seen today...

Okay, to start:

1) set up all of your cities in the world map - make sure you have one labelled "Parent". Set up your colony cities in the world map... for each one (up to 4), make sure that each is labelled as "Our Colony", "Inactive", and "Pay Tribute".
2) return to the main screen of the editor, click into the File menu, and click on "Save Settings".
3) of the two sections of the main screen, the top section is for parent city episodes only, while the bottom section is for colony episodes only... after you've done the "Save Settings", you should see the buttons in the bottom section named for your colonies.
4) in the upper section, have the appropriate number of rows - one for each parent city episode, with the last row labelled "Victory".
5) the way you want it, with a colony as the second episode, you would have only two rows in the upper section, like this:

1. "Colony" Settings |_|
2. "Victory" Settings |_|

6) if row number 1 is still labelled as "Parent", click on it until it says "Colony".
7) now your adventure (when completed) will consist of three episodes... Parent, Colony, Victory (Parent).

That first (left) button in the parent city rows is the "coming up next" button... it tells you what the player will be doing next after they finish the parent city episode that row represents. So with it set as above, the player will do a Parent city episode (the game always starts with a parent city episode), then the next thing they do (the second episode) will be a Colony, as represented by that 'Next' button... all colonies are one episode only, after which the player automatically returns to the parent city and does the next episode... in this case, the "Victory" episode.

So your adventure (when set as above) will run like this:

p1. Parent city episode #1... filling the goals sends the player to a colony
c1. Colony episode... filling the goals sends the player back to the parent city (this episode is listed in the bottom section of the main screen; that's where you set up the map and settings for that colony)
p2. Parent city episode (Victory)... filling the goals completes the adventure.

Do NOT set up an event in the first episode that makes the colony go Active... that will happen automatically when the player finishes that first episode and is tossed out to the colony selection screen.

Remember that there must be the same number - or more - of colonies listed in the bottom section as there are in the top... having more potential colonies than there are actual colony episodes just means that the player can play the adventure differently the next time around, doing the colonies in a different order or doing a colony they didn't do the first time around. Until you're used to the colony progression, however (clicking that parent city 'Next' button to change it to 'Colony'), I'd stick with an equal number of colonies and colony episodes.

For example, you can have four colonies (the maximum) listed in the bottom section of the screen, but only one colony episode listed at the top... this just means that the player will need to choose which colony to do (which leads us into resources, trade, etc... check out my myth-Edit site (listed below) for more info).


David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis

[This message has been edited by Nightwolf (edited 01-18-2003 @ 00:44 AM).]

posted 03-05-03 14:14 ET (US)     5 / 23       
I'm also getting the error message about the colony number: "Wrong Number of Colonies - found 3, expected 0 - OK?"

I finally managed to fix my food type problem and now I'm getting this. If you want to look at my settings screen, I took a pic of it and posted it HERE.

I'm also not sure I did the text correctly. I put the colony text down at the bottom, but I'm not sure how the parent colony text should be numbered. My colonies are episodes 3, 5, and 7. Please help?

posted 03-05-03 23:34 ET (US)     6 / 23       
Text for the Parent City episodes goes at the top of the "Text_Template.txt" file... there are three entries for each parent city episode: Title, Introduction, and Complete. Just as they say... "Title" is the title of that particular episode (a 27 letter limit, I believe), "Introduction" is what the player sees at the beginning of an episode, and any time they click on the Goals button during that episode, and "Complete" is what they see when the episode finishes.

Each colony has 4 sections of text: Title, Introduction, Complete, and Selection. The first three are just as above... the "Selection" text is what they'll see on the world map screen during colony selection; something which gives them enough information to decide which colony to do (the limit on Selection text is 215, I think).

The text file is divided just like the editor screen... the parent city episodes at the top, the colonies at the bottom. There's a maximum of 10 parent city episodes, 4 colonies. Just match the section of text file with your actual settings screen... the first parent city episode (the top one) on the editor screen will be the top section of text file, etc. To make sure you've got them properly matched, click on the little square button at the end of each row to see the text appear on the right.


David "Nightwolf" Masters
my Facebook page

"When facism comes to America, it will be waving the flag and carrying a cross." -- Sinclair Lewis
posted 12-03-11 10:12 ET (US)     7 / 23       
Hi there!

I know this sticky is old and that it has been ages since a comment and/or reply, but I have a serious problem now concerning the Poseidon Adventure Editor and Colony missions.

I followed each and every hint, tip and/or step found in this topic and the help file that comes with the game, to the letter. Have tried to see if a combination of those worked for days now. But I simply can't get my own created adventure to move on past the parent city!

My world map lay-out:
#0 Parent City
#1 Colony, inactive.
When I save my world map settings it DOES show the colony at the bottom of the screen.

Me adventures look like this:
1. Parent city
2. Colony
3. Parent city
4. Victory

Now, I've tried everything. From only filling in the colony settings at the bottom of the screen till filling in both (top and bottom colony tab). Leaving things blank, alternating between top and bottom with filling in. From mythology till resources. I've tried everything! Even making sure that the colony is from the same culture I want to play with after creating.
In short: I have two options when it comes to setting a colony adventure.
1. If I've filled in everything (including goals) in the top section of the editor, I do get the goals to meet. But in my Parent City map (including what I've already built there in the first Parent episode).
2. If I let the goals for the Colony episode blank in the top screen but fill them in at the bottom, I simply get an Open Goal play in my Parent City.

No matter what I hustle around in settings, I always come back in my parent city after completing the first episode. With or without the goals meant for the colony mission.

Am I doing something horribly wrong????

Many thanks for the time reading (and hopefully helping),
Impreza (from the Netherlands).

P.S. Please feel free to ask for an explanation if I'm making no sence.

[This message has been edited by Impreza (edited 12-03-2011 @ 10:23 AM).]

posted 12-04-11 15:24 ET (US)     8 / 23       
Okay, on the parent episode list, it has options for "next episode" as "parent", "colony", or "victory". If I am understanding your problem, you are thinking of this as "location of this episode", but that's not right. If it is "parent", that means the next episode will be the next item on the list. If it is "colony", the next episode will be a colony episode, then it will return to the next item on the parent episode list when the colony episode is completed. So the way you have your adventure set up there would be two parent episodes, then a colony episode, then 2 more parent episodes, but you are thinking it is 1 parent episode, 1 colony episode, then another parent episode.

The first episode will always be the first item on the parent episode list and the victory episode will always be a parent episode. If it were the way you are thinking, it would be possible to start or end the game with a colony episode, or do two colony episodes without a parent in between, which it's not (without hacking the adventure file anyway).

[This message has been edited by DerangedDuck (edited 12-04-2011 @ 03:26 PM).]

posted 12-05-11 08:40 ET (US)     9 / 23       

Many thanks for your reply. Now I've tried the following settings for my adventures:

E1. Parent city
E2. Parent city
E3. Colony
E4. Parent city
E5. Victory

I don't start the adventure with a colony nor do I end it with one. In between the colony episodes, I have at least 2 Parent city episodes. The game still refuses to move to the colony.

The strange thing I find: The goals I set for the colony episode DO apear, but in my Parent city....
posted 12-05-11 13:11 ET (US)     10 / 23       
Impreza: Are you sure you're using colony settings instead of parent city settings?
Colony settings are on the bottom of the editor - for colony to 'appear', both goals and a map for said colony must be provided.

Also make sure that you don't have colony set as 'hidden' on the World map - that can also screw up the game.
posted 12-05-11 13:21 ET (US)     11 / 23       
Dear Haspen.

You to many thanks for trying to help me out here.

I've tried the following thus far:
- Only the colony settings at the bottom of the screen.
- Only filling in the colony settings at the top of the screen.
- Filling both of them.
- Filling in various of different data between the two.
- The colony status in the world map has been varied between Inactive and active on countless accasions while trying the previous steps out....

Nothing seems to work....

If I fill in the colony data at the bottom of the screen, I don't get a thing. I simple skip to the next parent city episode or get an open goal play in the parent city.
If I fill in all data in the colony adventure (top part), I get all goals but in the parent city....

Seriously... I'm doing something horibly wrong..... If you'd like, I could try to get some screen-shots of my settings up here.
posted 12-08-11 23:46 ET (US)     12 / 23       
Suggestion: Load somebody else's adventure into the editor. At least some of the downloadable adventures on this site have the .set and .map files included.
posted 12-09-11 05:51 ET (US)     13 / 23       
That is a great suggestion! Haven't thought about that....
That way I can figure out what I'm doing wrong by comparing the settings!
posted 12-09-11 14:10 ET (US)     14 / 23       
My adventures have all of the editor-needed files, in case you look for any
posted 12-25-11 05:53 ET (US)     15 / 23       
Thank you Haspen.

I'd love to try it, where can I find it? I've tried to download other custom adventures generously provided here, but can;t find any download-links to them *blush*
posted 12-25-11 09:30 ET (US)     16 / 23       
Here's the list of my adventures.

When you get into one, all you have to do is click the red 'download file' and download it to your 'Adventures' folder.

It needs to be 'Adventures/Name of Adventure here' folder format for the game to find them and show them on the 'Custom Game' list.

I hope I helped

[This message has been edited by Haspen (edited 12-25-2011 @ 09:32 AM).]

posted 01-19-12 11:32 ET (US)     17 / 23       
Hello Haspen!

I've downloaded and played your "Atlants on the East" adventure (great game by the way) and after playing it, I duplicated each and every adventure you created. In the very same order, the same settings (the Prt Scr button on my keyboard is worn out by now, used it a lot to make sure that had I had the very same settings as you had).
Your game runs perfectly, no flaws what so ever. Even the Colognies run great! But when I try to run my direct copy based on your came, I get the same problems as mentioned before.... The Colony adventures simply won't run.

Now, after a time of rummaging around on the Internet, I found out there where several game-packs launched over the years. Ranging from the orginal: Zeus master of Olympus game till: Zeus and Poseidon and (there after) Zeus, Poseidon, Caesar, Pharaoh and what not.
I have: The great empires II collection which includes: Zeus, Poseidon and Caesar. Bought second hand from a friend after my original Zeus, Master of Olympus CD-Rom gave out on me.

Could it be that the problem lies in there? The version I've got of the game?
posted 01-20-12 05:28 ET (US)     18 / 23       
Did you tried to patch Poseidon ?
Did you tried to desinstall_reinstall both Zeus and Poseidon ?
Seems to me that if an adventure is properly running and a perfect clone don't , maybe there is something wrong whith you editor ?
posted 01-21-12 06:12 ET (US)     19 / 23       
I've tried installing-removing-installing again countles of times. Haven't thought of patching the game yet... I'll give that a shot! Maybe that does the trick.

Thanks for the tip!
posted 02-25-12 09:52 ET (US)     20 / 23       
Hi there *waves*! Me again!

Just to let all of you know that the patches did the trick. I can now, finally, create my own adventures with working cologny episodes!

I want to thank everyone whom helped me out here. Besides solving my problem, I've also learned a lot about the Adventure Editing Tool in the process.

Many thanks to all of you!
posted 02-25-12 14:36 ET (US)     21 / 23       

I'm so glad that you made it work at last ^^
posted 03-11-12 18:18 ET (US)     22 / 23       
Couldn't have done it without the help of everyone here though. So I'm saying a big: Thank you! to all of you!

[This message has been edited by Impreza (edited 03-11-2012 @ 06:19 PM).]

posted 09-02-20 12:08 ET (US)     23 / 23       
is there a way to force the player to choose the colony episodes in a particular order? i would like to have 4 colonies with parent episodes happening between them, but need to be sure that the player picks them one by one in an order i specify. i have seen somewhere that the colony city can be temporarily changed by an event to 'rival' and therefore it would not be available for choosing, but i'm unsure if it works.
You must be logged in to post messages.
Please login or register

Hop to:    

Caesar IV Heaven | HeavenGames