You must be logged in to post messages.
Please login or register

Pharaoh: Scenario Design
Moderated by Granite Q, Gweilo

Hop to:    
Welcome! You are not logged in. Please Login or Register.5 replies
Caesar IV Heaven » Forums » Pharaoh: Scenario Design » Kingdom Map Error
Bottom
Topic Subject:Kingdom Map Error
Squidbrains
Pleb
posted 10-02-15 14:55 ET (US)         
I was designing a map and setting trade cities and trade routes. When I save the map and load it to play, one of the trade cities has no goods to buy or sell. I can open the trade route for 400 deben, but not trade anything. On the map in the builder though, that cities buys and sells several items. I can't figure out where or how they disappear from the map design to the actual game part.

Anyone ever see anything like this or have a suggestion what I might have done wrong?
AuthorReplies:
Brugle
HG Alumnus
posted 10-02-15 15:41 ET (US)     1 / 5       
I haven't seen that error. Have you carefully looked through the Mission Editor Guide to make sure you followed the requirements? For example, is there a route for that city? For another example, does each of the cities (trade or not) that are referenced have a unique number between 1 and 19?
Granite Q
Angel
posted 10-03-15 01:15 ET (US)     2 / 5       
Squidbrains, I agree with Brugle: I think you need to check every detail of all the cities in your map.
Errors do occur sometimes for strange reasons!
Post back and let us know how you get on.
Sajuuk
Pleb
posted 10-03-15 03:10 ET (US)     3 / 5       
I have had a similar bug where I've set the buy/sell items for a city, but after saving the map and going to it properly, all of the items are gone and the city essentially sells or buys no goods. This happened on a map I started developing but ended up abandoning due to a lack of interest in Pharaoh at the time.

The only thing I could see as a fix is to reset the map and start over, or to simply set other items for that city.

If my memory is serving me right, this happened when I had set up some cities on the map (simply by deleting many of the icons from the Default map to set up my "Empire" of that map), then added a new city on the empire map through the button at the bottom, which seemed to corrupt one of the other cities, forcing me to have to "rebuild" the Empire Map by using the Reset button to get all the cities back on the map and going through the same process again. Do be aware that I can't remember exactly what I did, since this was some years ago when it happened to me.

It is annoying and irritating when it happens though!

[This message has been edited by Sajuuk (edited 10-03-2015 @ 03:14 AM).]

maydayp
Pleb
posted 10-03-15 16:30 ET (US)     4 / 5       
I get this all the time, Check the supply for the city where the items aren't appearing. I was editing an older map, and found that some items were set to "no supply" even though I hadn't set them to that.
go into mission editor, click on "Kingdom", select "edit object" and select the city(s) that are missing items go to "demand" and ensure that they either say "high", "low", or "med". If it's blank it will not show up.
took me years to figure this out. Not that I looked very hard...
(not guaranteeing that this is your issue.)
Squidbrains
Pleb
posted 10-03-15 16:58 ET (US)     5 / 5       
Thanks all. Demand was a good idea but I checked and that wasn't the problem. I had to just delete and recreate it, but that worked.
You must be logged in to post messages.
Please login or register

Hop to:    

Caesar IV Heaven | HeavenGames