You must be logged in to post messages.
Please login or register

Pharaoh: Game Help
Moderated by VitruviusAIA, Gweilo

Hop to:    
Welcome! You are not logged in. Please Login or Register.3 replies
Caesar IV Heaven » Forums » Pharaoh: Game Help » Weird problem
Topic Subject:Weird problem
posted 08-11-19 02:24 ET (US)         
Hi everyone!
I am experiencing something really weird with Pharaoh.
I recently translated in Italian my version of Pharaoh that I downloaded from steam (and just to be safe I kept the English version's files in a different folder).
Now all of a sudden, after a few plays, the workers in the buildings don't show up anymore. To check if a building is functioning I have to manually open the overlay and check.
I read online that the problem would be solved by restarting my pc but that did not help in my case.
The weird part is that both versions of Pharaoh (English and Italian on my pc) have the same issue.
Do you guys have any clue if its a specific file I have to replace or something that could help me?

Ps: Thanks for all the good guides and topics in this forum! Thanks to that playing Pharaoh is so much easier and enjoyable.
HG Alumnus
posted 08-11-19 07:25 ET (US)     1 / 3       
Hi DorianDeo, welcome to Pharaoh Heaven.

When that problem occurred for me (it has been very rare), rebooting the PC fixed it. If rebooting the PC doesn't fix it for you, I don't know what to suggest.
posted 08-11-19 23:22 ET (US)     2 / 3       
A couple years ago I had similar problems after spending time in web browser to look up info while Cleo was running. Widescreen patch was used with Cleo in Windowed mode.

I would pull the Window up above the top of the screen and release it which caused the window to self adjust down a little. Buildings would start animations again, re-adjusted window to desired location.

Probably had something to do with Windows putting Cleo into background app mode. shrug.

[This message has been edited by user3 (edited 08-11-2019 @ 11:29 PM).]

posted 08-12-19 04:38 ET (US)     3 / 3       
Hey guys!
Thank you so much for your replies, I tried both methods and got no results.
Now I am gonna try to:

- Uninstall the game
- Wipe the free space on my drive so the game is gone
- Restart the PC
- Buy it from GOG (now I have the Steam version and I don't want to be paranoic but I believe this problem started when steam all of a sudden started recording my hours of playing, didn't before) so it's an offline version.
- Install the game
- Install the widescreen fix
- Install the Italian language

Going through all this trouble just to have a perfect version of this beautiful game?

Worth it...
I just hope this is gonna work because otherwise, I don't know what else to do.

UPDATE:In case someone needs this in the future.
Nothing worked apparantly until I thought about the recent updates that I have installed on my pc (gpu drivers,windows updates and similar).
Reinstalling the GPU drivers seemed to have fixed the problem.

[This message has been edited by DorianDeo (edited 08-14-2019 @ 02:06 AM).]

You must be logged in to post messages.
Please login or register

Hop to:    

Caesar IV Heaven | HeavenGames